<!DOCTYPE html><html lang="en-US" class="html_stretched responsive av-preloader-disabled av-default-lightbox html_header_top html_logo_left html_main_nav_header html_menu_right html_slim html_header_sticky html_header_shrinking_disabled html_header_topbar_active html_mobile_menu_tablet html_header_searchicon html_content_align_center html_header_unstick_top html_header_stretch_disabled html_minimal_header html_burger_menu html_av-submenu-hidden html_av-submenu-display-hover html_av-overlay-full html_av-submenu-noclone html_entry_id_3215 av-no-preview html_burger_menu_active "><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><title>Language Server Protocol: A Language Server For DOT With Visual Studio Code - Federico Tomassetti - Software Architect</title><style id="rocket-critical-css">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</style><meta name="description" content="This tutorial will show you how to build a Language Server for the DOT Language and use it from Visual Studio Code. Let&#039;s use the Langague Server Protocol!" /><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://tomassetti.me/language-server-dot-visual-studio/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Language Server Protocol: A Language Server For DOT With Visual Studio Code - Federico Tomassetti - Software Architect" /><meta property="og:description" content="This tutorial will show you how to build a Language Server for the DOT Language and use it from Visual Studio Code. Let&#039;s use the Langague Server Protocol!" /><meta property="og:url" content="https://tomassetti.me/language-server-dot-visual-studio/" /><meta property="og:site_name" content="Federico Tomassetti - Software Architect" /><meta property="article:publisher" content="https://www.facebook.com/tomassetticonsultant/" /><meta property="article:tag" content="language server protocol" /><meta property="article:section" content="Language Engineering" /><meta property="article:published_time" content="2017-04-05T09:37:18+00:00" /><meta property="article:modified_time" content="2020-05-11T15:59:24+00:00" /><meta property="og:updated_time" content="2020-05-11T15:59:24+00:00" /><meta property="og:image" content="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg" /><meta property="og:image:secure_url" content="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="This tutorial will show you how to build a Language Server for the DOT Language and use it from Visual Studio Code. Let&#039;s use the Langague Server Protocol!" /><meta name="twitter:title" content="Language Server Protocol: A Language Server For DOT With Visual Studio Code - Federico Tomassetti - Software Architect" /><meta name="twitter:site" content="@ftomasse" /><meta name="twitter:image" content="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg" /><meta name="twitter:creator" content="@ftomasse" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://tomassetti.me/#organization","name":"Strumenta S.R.L.","url":"https://tomassetti.me/","sameAs":["https://www.facebook.com/tomassetticonsultant/","https://www.linkedin.com/in/federicotomassetti/","https://www.youtube.com/channel/UC-d-doLMBYrzLbkkz23qMPA","https://twitter.com/ftomasse"],"logo":{"@type":"ImageObject","@id":"https://tomassetti.me/#logo","inLanguage":"en-US","url":"https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2018/08/Logo_Standard_nowriting_trasparente.png","width":476,"height":821,"caption":"Strumenta S.R.L."},"image":{"@id":"https://tomassetti.me/#logo"}},{"@type":"WebSite","@id":"https://tomassetti.me/#website","url":"https://tomassetti.me/","name":"Federico Tomassetti - Software Architect","inLanguage":"en-US","description":"Building languages and tools to empower people","publisher":{"@id":"https://tomassetti.me/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://tomassetti.me/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://tomassetti.me/language-server-dot-visual-studio/#primaryimage","inLanguage":"en-US","url":"https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg","width":1024,"height":512,"caption":"A Language Server For DOT With Visual Studio Code"},{"@type":"WebPage","@id":"https://tomassetti.me/language-server-dot-visual-studio/#webpage","url":"https://tomassetti.me/language-server-dot-visual-studio/","name":"Language Server Protocol: A Language Server For DOT With Visual Studio Code - Federico Tomassetti - Software Architect","isPartOf":{"@id":"https://tomassetti.me/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://tomassetti.me/language-server-dot-visual-studio/#primaryimage"},"datePublished":"2017-04-05T09:37:18+00:00","dateModified":"2020-05-11T15:59:24+00:00","description":"This tutorial will show you how to build a Language Server for the DOT Language and use it from Visual Studio Code. Let's use the Langague Server Protocol!","potentialAction":[{"@type":"ReadAction","target":["https://tomassetti.me/language-server-dot-visual-studio/"]}]},{"@type":"Article","@id":"https://tomassetti.me/language-server-dot-visual-studio/#article","isPartOf":{"@id":"https://tomassetti.me/language-server-dot-visual-studio/#webpage"},"author":{"@id":"https://tomassetti.me/#/schema/person/9d34d5e44624f1376e9614c2a25cf248"},"headline":"Language Server Protocol: A Language Server For DOT With Visual Studio Code","datePublished":"2017-04-05T09:37:18+00:00","dateModified":"2020-05-11T15:59:24+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://tomassetti.me/language-server-dot-visual-studio/#webpage"},"publisher":{"@id":"https://tomassetti.me/#organization"},"image":{"@id":"https://tomassetti.me/language-server-dot-visual-studio/#primaryimage"},"keywords":"language server protocol","articleSection":"Language Engineering","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://tomassetti.me/#/schema/person/9d34d5e44624f1376e9614c2a25cf248","name":"Gabriele Tomassetti","description":"I started developing software to make a football management simulation and never stopped. I love C# and like a whole lot of other languages.","sameAs":[]}]}</script> <link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//mk0tuzolorusfnc7thxk.kinstacdn.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Federico Tomassetti - Software Architect &raquo; Feed" href="https://tomassetti.me/feed/" /><link rel="alternate" type="application/rss+xml" title="Federico Tomassetti - Software Architect &raquo; Comments Feed" href="https://tomassetti.me/comments/feed/" /> <script type='text/javascript'>if(!document.cookie.match(/aviaPrivacyGoogleWebfontsDisabled/)){
				(function() {
					var f = document.createElement('link');
					
					f.type 	= 'text/css';
					f.rel 	= 'stylesheet';
					f.href 	= '//fonts.googleapis.com/css?family=Lato:300,400,700';
					f.id 	= 'avia-google-webfont';
					
					document.getElementsByTagName('head')[0].appendChild(f);
				})();
			}</script> <link data-minify="1" rel='preload' id='avia-grid-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/grid-e7f86a4957050d86bbdde2be4b2e329c.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-base-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/base-9ee43dd72bee9b2e9372a5d41dfb2cfd.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-layout-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/layout-9d9e2151e6dfc7e5f9e836d3932cd249.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-blog-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/blog/blog-18576e4bf2a5d29be26c86a7d9e1c867.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-postslider-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/postslider/postslider-989c704f7f2a809af837b8e670cd0853.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-button-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/buttons/buttons-134ef1e4b4f1459379c2fc85ac863cbe.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-buttonrow-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/buttonrow/buttonrow-e2c888d48bc63472adaaa4f495043db6.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-button-fullwidth-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/buttons_fullwidth/buttons_fullwidth-254d86a461616beaf79576d06cd34c20.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-catalogue-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/catalogue/catalogue-adbb6d96c9a1738e54bee68a79d32810.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-comments-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/comments/comments-8df61ebd5ffecb3e3d2e0f8dfdba3021.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-contact-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/contact/contact-0f3a49a8560a6238f55c9d2127ffeb76.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-countdown-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/countdown/countdown-7afa04e6b150c054d2c4789014570bac.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-gallery-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/gallery/gallery-7700f83f6eb0be9afd295fd2e1293fea.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-gridrow-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/grid_row/grid_row-a75f88bea377b403e886c709b5ad57cf.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-heading-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/heading/heading-b7dddd1ef4275029a57b9a1517182880.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-hr-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/hr/hr-be01ac5c2ab2e5bdbcfbf150e32877e0.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-icon-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/icon/icon-da0406313b8462d480e535bb05f5f50c.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-iconlist-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/iconlist/iconlist-6088b3605f42a243a31c7547c92e7daa.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-image-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/image/image-2da44520fb6135c9345d7a3f78d7f638.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-magazine-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/magazine/magazine-fc5022a0047a03c485f988cd70381467.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-promobox-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/promobox/promobox-0d9df544506622d9978fcde68065845b.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-slideshow-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow/slideshow-dba83fd5b8d30bff2fd33416275f9c68.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-slideshow-fullsize-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullsize/slideshow_fullsize-fe118d93c104a09fe9cb8f20f63dadb2.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-slideshow-ls-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider/slideshow_layerslider-a349afb13837bc36afbd868e155babf0.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-social-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/social_share/social_share-e981254c3b50efafac2cc9a1c1b9c905.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-tabs-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/tabs/tabs-a7a217b2cdef7d7317f82ac3ff818c81.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-testimonials-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/testimonials/testimonials-6b29171c1f09c44f76fc7f3b18ff6b98.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-module-video-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/video/video-907cc2ae456a4fc8839931e64a286834.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='wp-block-library-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-includes/css/dist/block-library/style.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify}</style><link data-minify="1" rel='preload' id='fi_buttons-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/feedly-insight/css/fi-buttons-deprecated-25fa38b71a8609678b12c06dbaad2860.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='sb_bar-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/swifty-bar/public/assets/css/sb-bar-public-bf0134b2d24b0c6e4e6b5423991a6d0f.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='tve_style_family_tve_flt-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/thrive-leads/tcb/editor/css/thrive_flat-3a109a78ff4eac71f3856ec4009d4665.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='tve_leads_forms-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/thrive-leads/editor-layouts/css/frontend-2.2.13.2.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-scs-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/shortcodes-143bf9025df50d4ca3f24aae5b70c92b.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-popup-css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/aviapopup/magnific-popup-3aba24496166b48da31e47e534851e67.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='screen' /><link data-minify="1" rel='preload' id='avia-lightbox-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/avia-snippet-lightbox-64cad3d2c9d77d18b77c1cf70633f581.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='screen' /><link data-minify="1" rel='preload' id='avia-cookie-css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/avia-snippet-cookieconsent-bedea0a358c588d449bdd7c4f95a5996.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='screen' /><link data-minify="1" rel='preload' id='avia-widget-css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/avia-snippet-widget-3bb4c2bac224a946f94a272008eeb881.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='screen' /><link data-minify="1" rel='preload' id='avia-dynamic-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/uploads/dynamic_avia/tomassetti-214e93ce18069c712a9bbe7dca72a848.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-custom-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/custom-ea2bb2e63ecf88c9937492e1706413c4.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='avia-style-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/tomassetti/style-b224b5538d82adcffaed3add5922da9b.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='easy_table_style-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/easy-table/themes/default/style-61380df45b9199a4a87f6de0f5c2f6ad.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='enlighter-local-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/enlighter/resources/EnlighterJS.min-3.11.0.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='jetpack_css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack-cb9b5a4a54629bc9e9f25bd878449a45.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/convertkit/resources/frontend/jquery.cookie.min-1.4.0.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var ck_data = {"ajaxurl":"https:\/\/tomassetti.me\/wp-admin\/admin-ajax.php","post_has_tag":""}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/convertkit/resources/frontend/wp-convertkit-b53f848b1659972f31b38094ed29d309.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var admin_urls = {"admin_ajax":"https:\/\/tomassetti.me\/wp-admin\/admin-ajax.php","post_id":"3215","postNonce":"50e02cff40"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/swifty-bar/public/assets/js/sb-bar-public-670927006f9c2ec901feba83f98843ac.js' defer></script> <link rel='https://api.w.org/' href='https://tomassetti.me/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tomassetti.me/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4" /><link rel='shortlink' href='https://wp.me/p4K5DS-PR' /> <script type="text/javascript">var opGetCookie = function (name) {
            var value = "; " + document.cookie;
            var parts = value.split("; " + name + "=");
            if (parts.length == 2) return parts.pop().split(";").shift();
        };

        var opDomIsReady = (function(opDomIsReady) {
            var isBrowserIeOrNot = function() {
                return (!document.attachEvent || typeof document.attachEvent === "undefined" ? 'not-ie' : 'ie');
            };

            opDomIsReady = function(callback) {
                if(callback && typeof callback === 'function'){
                    if(isBrowserIeOrNot() !== 'ie') {
                        document.addEventListener("DOMContentLoaded", function() {
                            return callback();
                        });
                    } else {
                        document.attachEvent("onreadystatechange", function() {
                            if(document.readyState === "complete") {
                                return callback();
                            }
                        });
                    }
                } else {
                    console.error('The callback is not a function!');
                }
            };

            return opDomIsReady;
        })(opDomIsReady || {});

        (function(document, window, domIsReady) {
            opDomIsReady(function() {
                function doStuff(){
                    if(window.cid !== undefined){
                        let gaId = opGetCookie('_gid');
                        if(gaId === undefined) return;
                        let gumLinks = document.querySelectorAll('[href*="https://gum.co"]');
                        if (gumLinks.length !== 0) {
                            gumLinks.forEach(function (item) {
                                let href = item.href;
                                if(href.includes('?')){
                                    item.href = href + '&ga_id=' + gaId + '&cid=' + window.cid;
                                }else{
                                    item.href = href + '?ga_id=' + gaId + '&cid=' + window.cid;
                                }

                            })
                        }
                    }else{
                        setTimeout(doStuff,50)
                    }

                }

                doStuff();
            })
        })(document, window, opDomIsReady);</script> <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1814680788781617'); // Insert your pixel ID here.
fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1814680788781617&ev=PageView&noscript=1" /></noscript><link rel='dns-prefetch' href='//v0.wordpress.com' /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="alternate" type="application/rss+xml" title="Federico Tomassetti - Software Architect RSS2 Feed" href="https://tomassetti.me/feed/" /><link rel="pingback" href="https://tomassetti.me/xmlrpc.php" /> <!--[if lt IE 9]><script src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/js/html5shiv.js"></script><![endif]--><style type="text/css" id="tve_global_variables"></style> <script type="text/javascript">'use strict';var avia_is_mobile=!1;if(/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)&&'ontouchstart' in document.documentElement){avia_is_mobile=!0;document.documentElement.className+=' avia_mobile '}
else{document.documentElement.className+=' avia_desktop '};document.documentElement.className+=' js_active ';(function(){var e=['-webkit-','-moz-','-ms-',''],n='';for(var t in e){if(e[t]+'transform' in document.documentElement.style){document.documentElement.className+=' avia_transform ';n=e[t]+'transform'};if(e[t]+'perspective' in document.documentElement.style)document.documentElement.className+=' avia_transform3d '};if(typeof document.getElementsByClassName=='function'&&typeof document.documentElement.getBoundingClientRect=='function'&&avia_is_mobile==!1){if(n&&window.innerHeight>0){setTimeout(function(){var e=0,o={},a=0,t=document.getElementsByClassName('av-parallax'),i=window.pageYOffset||document.documentElement.scrollTop;for(e=0;e<t.length;e++){t[e].style.top='0px';o=t[e].getBoundingClientRect();a=Math.ceil((window.innerHeight+i-o.top)*0.3);t[e].style[n]='translate(0px, '+a+'px)';t[e].style.top='auto';t[e].className+=' enabled-parallax '}},50)}}})();</script><style type="text/css" id="thrive-default-styles"></style><link rel="icon" href="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2019/07/cropped-federico-tomassetti-software-architect-icon_large-32x32.png" sizes="32x32" /><link rel="icon" href="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2019/07/cropped-federico-tomassetti-software-architect-icon_large-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2019/07/cropped-federico-tomassetti-software-architect-icon_large-180x180.png" /><meta name="msapplication-TileImage" content="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2019/07/cropped-federico-tomassetti-software-architect-icon_large-270x270.png" /><style type="text/css" id="wp-custom-css">#header-bar{bottom:0;border-top:1px solid rgb(153,153,153);padding:5px 20px 0}#header-bar img{border-radius:50%;border:1px solid #000;width:80px;box-shadow:3px 3px 3px rgba(0,0,0,.1)}#header-bar img:hover{border:1px solid red;box-shadow:3px 3px 3px rgba(230,0,0,.3)}.explanation{background-color:#bbb;text-shadow:1px 1px 1px rgba(0,0,0,.1);font-family:'Alegreya SC',Georgia,serif;color:#000;padding:4px;border:2px #000 solid;border-radius:5px;display:none;margin-bottom:20px;margin-top:10px}#header-bar div{padding-right:10px;display:inline-block}#header-bar div:hover .explanation{display:inline-block;position:absolute}#header-bar div:hover img{opacity:.8}div#pp-textmiddle{padding:0}</style><style type='text/css'>@font-face{font-family:'entypo-fontello';font-weight:400;font-style:normal;font-display:auto;src:url(https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot);src:url('https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?#iefix') format('embedded-opentype'),url(https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.woff) format('woff'),url(https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.ttf) format('truetype'),url('https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.svg#entypo-fontello') format('svg')}#top .avia-font-entypo-fontello,body .avia-font-entypo-fontello,html body [data-av_iconfont='entypo-fontello']:before{font-family:'entypo-fontello'}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script> </head><body id="top" class="post-template-default single single-post postid-3215 single-format-standard rtl_columns stretched lato arial-websave arial" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div id='wrap_all'><header id='header' class='all_colors header_color light_bg_color av_header_top av_logo_left av_main_nav_header av_menu_right av_slim av_header_sticky av_header_shrinking_disabled av_header_stretch_disabled av_mobile_menu_tablet av_header_searchicon av_header_unstick_top av_minimal_header av_bottom_nav_disabled av_header_border_disabled' role="banner" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div id='header_meta' class='container_wrap container_wrap_meta av_icon_active_left av_extra_header_active av_secondary_right av_entry_id_3215'><div class='container'><ul class='noLightbox social_bookmarks icon_count_4'><li class='social_bookmarks_twitter av-social-link-twitter social_icon_1'><a target="_blank" aria-label="Link to Twitter" href="https://twitter.com/ftomasse" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Twitter'><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_linkedin av-social-link-linkedin social_icon_2'><a target="_blank" aria-label="Link to Linkedin" href="https://ie.linkedin.com/in/federicotomassetti" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Linkedin'><span class='avia_hidden_link_text'>Linkedin</span></a></li><li class='social_bookmarks_mail av-social-link-mail social_icon_3'><a aria-label="Link to Mail" href="/cdn-cgi/l/email-protection#1274777677607b717d52667d7f7361617766667b3c7f77" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Mail'><span class='avia_hidden_link_text'>Mail</span></a></li><li class='social_bookmarks_rss av-social-link-rss social_icon_4'><a aria-label="Link to Rss this site" href='https://tomassetti.me/feed/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Rss'><span class='avia_hidden_link_text'>Rss</span></a></li></ul></div></div><div id='header_main' class='container_wrap container_wrap_logo'><div class='container av-logo-container'><div class='inner-container'><span class='logo'><a href='https://tomassetti.me/'><img height='100' width='300' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20100'%3E%3C/svg%3E" alt='Federico Tomassetti - Software Architect' data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/07/federico-tomassetti-software-architect-300.png" /><noscript><img height='100' width='300' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/07/federico-tomassetti-software-architect-300.png' alt='Federico Tomassetti - Software Architect' /></noscript></a></span><nav class='main_menu' data-selectname='Select a page' role="navigation" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><div class="avia-menu av-main-nav-wrap"><ul id="avia-menu" class="menu av-main-nav"><li id="menu-item-4159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-top-level menu-item-top-level-1"><a href="https://strumenta.com/services/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Services</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-4164" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-top-level menu-item-top-level-2"><a href="https://strumenta.com/products" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Products</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-3277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-3"><a href="https://tomassetti.me/learning-build-languages/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Learning to build languages</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-3276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-4"><a href="https://tomassetti.me/learning-process-code/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Learning to process code</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-3996" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-5"><a href="https://tomassetti.me/antlr-course/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Using ANTLR Like a Professional</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-3278" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-6"><a href="https://tomassetti.me/newsletter/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Newsletter</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-2572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-top-level menu-item-top-level-7"><a href="https://tomassetti.me/about-me/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">About me</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-5959" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-top-level menu-item-top-level-8"><a href="https://strumenta.com/contact-us/" itemprop="url"><span class="avia-bullet"></span><span class="avia-menu-text">Let&#8217;s Talk</span><span class="avia-menu-fx"><span class="avia-arrow-wrap"><span class="avia-arrow"></span></span></span></a></li><li id="menu-item-search" class="noMobile menu-item menu-item-search-dropdown menu-item-avia-special"> <a href="?s=" rel="nofollow" data-avia-search-tooltip=" &lt;form action=&quot;https://tomassetti.me/&quot; id=&quot;searchform&quot; method=&quot;get&quot; class=&quot;&quot;&gt; &lt;div&gt; &lt;input type=&quot;submit&quot; value=&quot;&quot; id=&quot;searchsubmit&quot; class=&quot;button avia-font-entypo-fontello&quot; /&gt; &lt;input type=&quot;text&quot; id=&quot;s&quot; name=&quot;s&quot; value=&quot;&quot; placeholder='Search' /&gt; &lt;/div&gt; &lt;/form&gt;" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Search</span></a></li><li class="av-burger-menu-main menu-item-avia-special "> <a href="#"> <span class="av-hamburger av-hamburger--spin av-js-hamburger"> <span class="av-hamburger-box"> <span class="av-hamburger-inner"></span> <strong>Menu</strong> </span> </span> </a></li></ul></div></nav></div></div></div><div class='header_bg'></div></header><div id='main' class='all_colors' data-scroll-offset='88'><div class='stretch_full container_wrap alternate_color light_bg_color title_container'><div class='container'><strong class='main-title entry-title '><a href='https://tomassetti.me/blog/' rel='bookmark' title='Permanent Link: Blog' itemprop="headline">Blog</a></strong></div></div><div class='container_wrap container_wrap_first main_color sidebar_right'><div class='container template-blog template-single-blog '><main class='content units av-content-small alpha av-blog-meta-comments-disabled' role="main" itemscope="itemscope" itemtype="https://schema.org/Blog"><article class='post-entry post-entry-type-standard post-entry-3215 post-loop-1 post-parity-odd post-entry-last single-small with-slider post-3215 post type-post status-publish format-standard has-post-thumbnail hentry category-language-engineering tag-language-server-protocol' itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost"><div class='entry-content-wrapper clearfix standard-content'><header class="entry-content-header"><h1 class='post-title entry-title ' itemprop="headline"> <a href='https://tomassetti.me/language-server-dot-visual-studio/' rel='bookmark' title='Permanent Link: Language Server Protocol: A Language Server For DOT With Visual Studio Code'>Language Server Protocol: A Language Server For DOT With Visual Studio Code <span class='post-format-icon minor-meta'></span> </a></h1><span class='post-meta-infos'><time class='date-container minor-meta updated'>April 5, 2017</time><span class='text-sep text-sep-date'>/</span><span class="blog-categories minor-meta">in <a href="https://tomassetti.me/category/language-engineering/" rel="tag">Language Engineering</a> </span><span class="text-sep text-sep-cat">/</span><span class="blog-author minor-meta">by <span class="entry-author-link"><span class="vcard author"><span class="fn"><a href="https://tomassetti.me/author/gtomassetti/" title="Posts by Gabriele Tomassetti" rel="author">Gabriele Tomassetti</a></span></span></span></span></span></header><div class="entry-content" itemprop="text"><div class="ttr_start"></div><div id="attachment_4336" style="width: 1034px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-4336" class="wp-image-4336 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20512'%3E%3C/svg%3E" alt="A Language Server For DOT With Visual Studio Code" width="1024" height="512" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg 1024w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-300x150.jpg 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-768x384.jpg 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-705x353.jpg 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-450x225.jpg 450w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg" /><noscript><img aria-describedby="caption-attachment-4336" class="wp-image-4336 size-full" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg" alt="A Language Server For DOT With Visual Studio Code" width="1024" height="512" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg 1024w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-300x150.jpg 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-768x384.jpg 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-705x353.jpg 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code-450x225.jpg 450w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><p id="caption-attachment-4336" class="wp-caption-text">The companion repository for this article is <a href="https://github.com/gabriele-tomassetti/language-server-dot">gabriele-tomassetti/language-server-dot </a></p></div><p>In a previous post we have seen how the <a href="https://tomassetti.me/what-is-the-language-server-protocol/">Language Server Protocol</a> can be a game changer in language development: we can now build support for one language and integrate it with all the IDEs compatible with this protocol.</p><p><strong>In this article we are going to see how easy is to build support for the <a href="https://en.wikipedia.org/wiki/DOT_(graph_description_language)">DOT Language</a> in Visual Studio Code.</strong></p><p><em>Note that Visual Studio Code now runs also on <strong>Mac</strong> and <strong>Linux</strong></em></p><p>To do this we are going to build a system composed of two elements:</p><ul><li>A server which will provide support for our language (DOT)</li><li>A very thin client that will be integrated in Visual Studio Code</li></ul><p>If you want to support another editor you must create a new client for that editor, but you could reuse the same server. In fact, the server is nothing else than a node app.</p><p>The <strong>code for this article</strong> is in its <a href="https://github.com/gabriele-tomassetti/language-server-dot">companion repository.</a> In this tutorial we are not going to show every little details. We are going to focus instead on the interesting parts. We will start slow and explain how to setup the client and then only the parts necessary to understand how everything works. So you have to refer to the repository if you want to see all the code and the configuration details.</p><h3>Language Server Protocol Recap</h3><p>If you haven&#8217;t read the <a href="https://tomassetti.me/what-is-the-language-server-protocol/">previous article</a> there is a few things that you may want to know. The protocol is based upon JSON-RPC, this means it is lightweight and simple both to use and to implement. In fact there are already editors that support it, such as Visual Studio Code and Eclipse, and libaries for many languages and formats.</p><p>The client informs the server when a document is opened or changed, and the server must mantain it&#8217;s own representation of the open documents. The client can also send requests that must be fullfilled by the server, such as requesting hover information or completion suggestions.</p><h2>DOT Language</h2><p>The DOT Language permits to describe graphs. A tool named Graphviz can read descriptions in DOT and generate nice pictures from those. Below you can see an example. It does not matter if you are not familiar with DOT. It is a very simple language that is perfect to show you how to use the Language Server Protocol in practice.</p><pre class="EnlighterJSRAW" data-enlighter-language="generic"> graph short {
     // This attribute applies to the graph itself
     size="1,1";
     a;
     // The node shape is changed.
     b [shape=box];
     // These are edges
     // You don't have to declare each node
     a -- b -- c [color=blue];
     // You don't have to use the ending ';'
     b -- d
 }</pre><p>From this graph Graphviz will generate this image:</p><p><img class="aligncenter size-medium wp-image-3247" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20214%20300'%3E%3C/svg%3E" alt="" width="214" height="300" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/graph-1-214x300.png" /><noscript><img class="aligncenter size-medium wp-image-3247" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/graph-1-214x300.png" alt="" width="214" height="300" /></noscript></p><p>&nbsp;</p><h2>Setup</h2><p>Before starting, we have to install a couple of things:</p><ol><li>VS Code extension generator: to generate a skeleton extension</li><li>VS Code extension for the DOT language: to register the DOT language</li></ol><h3>VS Code Extension Generator</h3><p>The generator can be installed and used the following way.</p><pre class="EnlighterJSRAW" data-enlighter-language="shell">npm install -g yo generator-code
yo code</pre><p>The generator will guide through the creation of an extension. In our case, we need to create one for the client, which is the proper VS Code extension.</p><p><img class="aligncenter wp-image-3257 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20944%20361'%3E%3C/svg%3E" alt="VSCode Extension Generator" width="944" height="361" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode.png 944w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-300x115.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-768x294.png 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-705x270.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-450x172.png 450w" data-lazy-sizes="(max-width: 944px) 100vw, 944px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode.png" /><noscript><img class="aligncenter wp-image-3257 size-full" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode.png" alt="VSCode Extension Generator" width="944" height="361" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode.png 944w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-300x115.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-768x294.png 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-705x270.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/vscode_yocode-450x172.png 450w" sizes="(max-width: 944px) 100vw, 944px" /></noscript></p><h3>VS Code Extension For The DOT Language</h3><p>The <strong>Language Support for the DOT language</strong> is an extension to register the DOT language with Visual Studio Code.</p><p>You can navigate to the extensions page</p><p><img class="aligncenter size-medium wp-image-3256" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20182'%3E%3C/svg%3E" alt="" width="300" height="182" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-300x182.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-768x466.png 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-705x427.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-450x273.png 450w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33.png 818w" data-lazy-sizes="(max-width: 300px) 100vw, 300px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-300x182.png" /><noscript><img class="aligncenter size-medium wp-image-3256" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-300x182.png" alt="" width="300" height="182" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-300x182.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-768x466.png 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-705x427.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33-450x273.png 450w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-04-at-17.43.33.png 818w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></p><p>Once you are there search for <em>dot </em>and install it.</p><p>You may wonder why we need an extension for the DOT Language. I mean, aren&#8217;t we building it one right now?</p><p>We are building a <em>Language Server</em> for the DOT Language, to implement things such as <strong>verifying the correcteness of the syntax or suggesting terms for autocompletion</strong>. The extension we are going to install provides instead basic stuff like syntax highlighting. It also associate the extension <code>.dot</code> files with the DOT language. These kinds of extensions are quite easy to create: they consist just of configuration files.</p><h3>Structure Of The Project</h3><p>The project will be composed by:</p><ul><li>a Language Protocol client</li><li>a Language Protocol server</li><li>a backend in C# and .NET Core that will provide the validation of the code</li></ul><p>So under the project there will be a folder <code>client</code>, that will contain the client code, a folder <code>server</code>, that will contain the server code, and a folder <code>csharp</code>, that will contain the C# service. There will also be a <code>data</code> folder, that will contain two files with a list of shapes and colors.</p><div id="attachment_3259" style="width: 1034px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-3259" class="wp-image-3259 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20552'%3E%3C/svg%3E" alt="Language Server Protocol architecture" width="1024" height="552" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1.jpeg 1024w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-300x162.jpeg 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-768x414.jpeg 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-705x380.jpeg 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-450x243.jpeg 450w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1.jpeg" /><noscript><img aria-describedby="caption-attachment-3259" class="wp-image-3259 size-full" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1.jpeg" alt="Language Server Protocol architecture" width="1024" height="552" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1.jpeg 1024w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-300x162.jpeg 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-768x414.jpeg 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-705x380.jpeg 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/architecture.002-1-450x243.jpeg 450w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><p id="caption-attachment-3259" class="wp-caption-text">The architecture of our application</p></div><p>Since client and server are actually node projects you have to install the node packages. And for the .NET Core project you have to restore the nuget packages using the well known commands inside the respective folders. More <a href="https://github.com/gabriele-tomassetti/language-server-dot">precise information is available in the repository</a>.</p><p>You have also to remember to start the C# project first (<code>dotnet run</code>) and then run the extension/client after that.</p><h2>1. The Client For The Language Server Protocol</h2><h3>Configuration Of The Client</h3><p>Our client is a Visual Studio Code extension, and a very simple one, given the integrated support in VS Code for the protocol.</p><p>We are writing it using TypeScript, a language that compiles to JavaScript. We are using TypeScript for two reasons:</p><ol><li>because it provides some useful features, such as strong typing</li><li>because it&#8217;s the default language for a VS Code extension.</li></ol><p>First we are going to setup how TypeScript will be compiled into Javascript, by editing <code>tsconfig.json</code>.</p><pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-highlight="11">{
    "compilerOptions": {
        "target": "es6",
        "module": "commonjs",
        "outDir": "out",
        "lib": [ "es6" ],
        "sourceMap": true
    },
    "exclude": [
        "node_modules",
        "server"
    ]
}</pre><p>In addition to the usual <code>node_modules</code>, we exclude the folder server, because it will contain the already compiled server. In fact, to simplify the use of the extension, the client will also contain the server. That is to say, we are going to create the server in another project, but we will output the source under the <code>client/server</code> folder, so that we could launch the extension with one command.</p><p>To do just that you can use <code>CTLR+Shift+B</code>, while you are in the server project, to automatically build and output the server under the client, as soon as you edit the code.</p><h3>Setting Up The Extension</h3><p>In <code>package.json</code> we include the needed packages and the scripts necessary to automatically compile, install the extension in our development environment, and run it.</p><p>For the most part it&#8217;s the default one, we just add a dependency.</p><pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-highlight="12">"scripts": {
    "vscode:prepublish": "tsc -p ./",
    "compile": "tsc -watch -p ./",
    "postinstall": "node ./node_modules/vscode/bin/install",
  },
  "devDependencies": {
    "@types/node": "^6.0.52",
    "typescript": "^2.1.5",
    "vscode": "^1.0.3"
  },
  "dependencies": {
    "vscode-languageclient": "^3.1.0"
  }</pre><p>The same file is also used to configure the extension.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">  "activationEvents": [
    "onLanguage:dot"
  ],  
  "contributes": {
    "configuration": {
      "type": "object",
      "title": "Client configuration",
      "properties": {
        "dotLanguageServer.maxNumberOfProblems": {
          "type": "number",
          "default": 100,
          "description": "Controls the maximum number of problems produced by the server."
        },
        "dotLanguageServer.trace.server": {
          "type": "string",
          "enum": [
            "off",
            "messages",
            "verbose"
          ],
          "default": "off",
          "description": "Traces the communication between VSCode and the dotLanguageServer service."
        }        
      }
    }
  },</pre><p>The setting <code>activationEvents</code> is used to configure when should the extension be activated, in our case for DOT files. The particular value (onLanguage:dot) is available because we have installed the extension for GraphViz (Dot) files. This is also the only thing that we strictly need from the DOT extensions. Alternatively, we could avoid installing the extension by adding the following to the <code>contributes</code> section. But doing this way we lose syntax highlighting.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">"contributes": {
    "languages": [
      {
        "id": "dot",        
        "extensions": [
          ".dot",
          ".DOT",
          ".gv"
        ]        
      }
    ],</pre><p>The <code>contributes </code>section <code></code>can also contain custom properties to modify the configuration of the extension. As an example we have a <code>maxNumberOfProblems</code> setting.</p><p>This is the time to call <em>npm install</em> so that the extension <em>vscode-languageclient</em> will be installed.</p><h3>Setting Up The Client</h3><p>Let&#8217;s see the code for the client. Copy it (or type it) in <em>src/extension.ts</em></p><pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-highlight="13,20-21,27,30,37">'use strict';

import * as path from 'path';
import * as fs from 'fs';

import { workspace, Disposable, ExtensionContext } from 'vscode';
import { LanguageClient, LanguageClientOptions, SettingMonitor, ServerOptions, TransportKind, TextEdit,
RequestType, TextDocumentIdentifier, ResponseError, InitializeError, State as ClientState, NotificationType } from 'vscode-languageclient';

export function activate(context: ExtensionContext) {

    // The server is implemented in another project and outputted there
    let serverModule = context.asAbsolutePath(path.join('server', 'server.js'));
    // The debug options for the server
    let debugOptions = { execArgv: ["--nolazy", "--debug=6009"] };
    
    // If the extension is launched in debug mode then the debug server options are used
    // Otherwise the  normal ones are used
    let serverOptions: ServerOptions = {
        run : { module: serverModule, transport: TransportKind.ipc },
        debug: { module: serverModule, transport: TransportKind.ipc, options: debugOptions }
    }
    
    // Options of the language client
    let clientOptions: LanguageClientOptions = {
        // Activate the server for DOT files
        documentSelector: ['dot'],
        synchronize: {
            // Synchronize the section 'dotLanguageServer' of the settings to the server
            configurationSection: 'dotLanguageServer',
            // Notify the server about file changes to '.clientrc files contained in the workspace
            fileEvents: workspace.createFileSystemWatcher('**/.clientrc')
        }
    }
    
    // Create the language client and start the client.
    let disposable = new LanguageClient('dotLanguageServer', 'Language Server', serverOptions, clientOptions).start();
    
    // Push the disposable to the context's subscriptions so that the 
    // client can be deactivated on extension deactivation
    context.subscriptions.push(disposable);
}</pre><p>This is the entire client: if you remove the comments it is just a bunch of lines long.</p><p>We first create and setup the server, for normal and debug sessions.</p><p>Then we take care of the client: on line 27 we order the client to call the server only for DOT files.</p><p>On line 37 we create the client with all the options and the informations it need.</p><p>This is quite easy, given the integrated support for the Language Server Protocol in Visual Studio Code. If you had to create a client from scratch, you would have to support the protocol JSON-RPC and configure the client to call the server whenever is needed: for instance, when the document changes or a completion suggestion is asked by the user.</p><h2>2. The Server For The Language Server Protocol</h2><p>To create the server you use the same procedure we use to create the client extension, with the command <code>yo code</code>. At the end the server and the client will be in one extensions, but during development we separate them for easier debugging.</p><p>The code will be automatically moved in the proper place thanks to the following options in <code>package.json</code>&#8230;</p><pre class="EnlighterJSRAW" data-enlighter-language="js">{
[..]
"scripts": {
    "compile": "installServerIntoExtension ../client ./package.json ./tsconfig.json &amp;&amp; tsc -p .",
    "watch": "installServerIntoExtension ../client ./package.json ./tsconfig.json &amp;&amp; tsc --watch -p ."    
  }
[..]
}</pre><p>&#8230;and <code>tsconfig.json</code>, that are created for the server.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">{
	"compilerOptions": {
		[..]
		"outDir": "../client/server",
		[..]
	},
	[..]
}</pre><h3>Creating the Server</h3><p>The basics of a server are equally easy: you just need to setup the connection and find a way to maintain a model of the documents.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">// Create a connection for the server. The connection uses Node's IPC as a transport
let connection: IConnection = createConnection(new IPCMessageReader(process), new IPCMessageWriter(process));

// Listen on the connection
connection.listen();

// Create a simple text document manager. The text document manager
// supports full document sync only
let documents: TextDocuments = new TextDocuments();
// Make the text document manager listen on the connection
// for open, change and close text document events
documents.listen(connection);

// After the server has started the client sends an initialize request. The server receives
// in the passed params the rootPath of the workspace plus the client capabilities. 
let workspaceRoot: string;</pre><p>The first thing to do is to create the connection and start listening.</p><p>Then we create an instance of <code>TextDocuments</code>, a class provided by Visual Studio Code to manage the documents on the server. In fact, for the server to work, it must maintain a model of the document on which the client is working on. This class listens on the connection and updates the model when the server is notified of a change.</p><pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-highlight="13-17">// hold a list of colors and shapes for the completion provider
let colors: Array&lt;string&gt;;
let shapes: Array&lt;string&gt;;

connection.onInitialize((params): InitializeResult =&gt; {  
    workspaceRoot = params.rootPath;
    colors = new Array&lt;string&gt;();
    shapes = new Array&lt;string&gt;();

    return {        
        capabilities: {
            // Tell the client that the server works in FULL text document sync mode
            textDocumentSync: documents.syncKind,
            // Tell the client that the server support code complete
            completionProvider: {
                resolveProvider: true,
                "triggerCharacters": [ '=' ]
            },
                        hoverProvider: true     
        }
    }
});</pre><p>On initialization <strong>we inform the client of the capabilities of the server</strong>. The Language Server Protocol can work in two different ways: either sending only the portion of the document that have changed or sending the whole document each time. We choose the latter and inform the client to send the complete document every time, on line 13.</p><p>We communicate to the client that <strong>our server supports autocompletion</strong>. In particular, on line 17, we say that it should only ask for suggestions after the character equals &#8216;=&#8217;. This makes sense for the DOT language, but in other cases you could choose to not specify any character or to specify more than one character.</p><p>We also <strong>support hover information</strong>: when the user leaves the mouse pointer over a token for some time we can provide additional information.</p><p>Finally we <strong>support validation</strong>, but we don&#8217;t need to tell the client about it. The rationale is that when we are informed of changes on the document we inform the client about any issue. So the client itself doesn&#8217;t have to do anything special, apart from notifying the server of any change.</p><h3>Implement Autocompletion</h3><p>The suggestions for autocompletion depends on the position of the cursor. For this reason the client specify to the server the document, and the position for each autocompletion request.</p><p>Given the simplicity of the DOT language there aren&#8217;t many element to consider for autocompletion. In this example we consider the values for colors and shapes. In this article we are going to see how to create suggestions for color, but the code in the repository contains also suggestions for shapes, which are created in the same way.</p><pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-highlight="11">connection.onCompletion((textDocumentPosition: TextDocumentPositionParams): CompletionItem[] =&gt; {
    let text = documents.get(textDocumentPosition.textDocument.uri).getText();  
    let lines = text.split(/\r?\n/g);   
    let position = textDocumentPosition.position;       

    if(colors.length == 0)
        colors=loadColors();

    let start = 0;

    for (var i = position.character; i &gt;= 0; i--) {
        if(lines[position.line][i] == '=')
        {           
            start = i;
            i = 0;
        }
    }   
});</pre><p>In the first few lines we set the proper values, and load the list of possible colors.</p><p>In particular, on line 2, <strong>we get the text of the document</strong>. We do that by calling the document manager, using a document URI, that we are given as input. In theory, we could also read the document directly from disk, using the provided document URI, but this way we would had only the version that is saved on disk. We would miss any eventual changes in the current version.</p><p>Then, on line 11, <strong>we find the position of the equals (=) character</strong>. You may wonder why we don&#8217;t just  use  <code>position.character - 1: </code>since the completion is triggered by that character don&#8217;t we already know the relative position of the symbol? The answer is yes, if we are starting a suggestion for a new item, but this isn&#8217;t always true. For instance it&#8217;s not true if there is already a value, but we want to change it.</p><div id="attachment_3220" style="width: 743px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-3220" class="wp-image-3220 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20733%20572'%3E%3C/svg%3E" alt="VSCode Complete for existing items" width="733" height="572" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete.png 733w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete-300x234.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete-705x550.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete-450x351.png 450w" data-lazy-sizes="(max-width: 733px) 100vw, 733px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete.png" /><noscript><img aria-describedby="caption-attachment-3220" class="wp-image-3220 size-full" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete.png" alt="VSCode Complete for existing items" width="733" height="572" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete.png 733w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete-300x234.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete-705x550.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/VSCode_complete-450x351.png 450w" sizes="(max-width: 733px) 100vw, 733px" /></noscript><p id="caption-attachment-3220" class="wp-caption-text">Autocomplete for an existing value</p></div><p>By making sure to find the position of the equals sign, we can always know if we are assigning a value to an option, and which option it is.</p><h3>Sending The Suggestions For Autocomplete</h3><p>These suggestions are used when the user typed &#8220;color=&#8221;.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">if(start &gt;= 5
&amp;&amp; lines[position.line].substr(start-5,5) == "color")
{
    let results = new Array&lt;CompletionItem&gt;();
    for(var a = 0; a &lt; colors.length; a++)
    {
        results.push({ 
            label: colors[a],
            kind: CompletionItemKind.Color,
            data: 'color-' + a
        })
    }
        
    return results;
}</pre><p>Now that we know the option name, if the option is <code>color</code> we send the list of colors. We provide them as an array of <code>CompletionItems</code>. On lines 26-28 you can see how they are created: you need a label and a <code>CompletionItemKind</code>. The &#8220;kind&#8221; value, at the moment, is only used for displaying an icon next to the suggestion.</p><p>The last element, <code>data</code>, is a field meant to contain custom data chosen by the developer. We are going to see later what is used for.</p><p>We always send all the colors to the client, Visual Studio Code itself will filter the values considering what the user is typing. This may or may not be a good thing, since this makes impossible to use abbreviations or nicknames to trigger a completion suggestion for something else. For example, you can&#8217;t type &#8220;Bill&#8221; to trigger &#8220;William Henry Gates III&#8221;.</p><h3>Giving Additional Information For The Selected CompletionItem</h3><p>You may want to give additional information to the user, to make easier choosing the correct suggestion, but you can&#8217;t send too much information at once. The solution is to use another event to give the necessary information once the user has selected one suggestion.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">connection.onCompletionResolve((item: CompletionItem): CompletionItem =&gt; {
    if(item.data.startsWith('color-'))
    {
        item.detail = 'X11 Color';
        item.documentation = 'http://www.graphviz.org/doc/info/colors.html';        
    }
    
    return item;
});</pre><p>The method <code>onCompletionResolve</code> is the one we need to use for doing just that.</p><p>It accepts a <code>CompletionItem</code> and it adds values to it. In our case if the suggestion is a color we give a link to the DOT documentation that contains the whole list of colors and we specify which color scheme is part of. Notice that the specification of DOT also supports color schemes other than the X11 one, but our autocomplete doesn&#8217;t.</p><h3>Validating A Document</h3><p>Now we are going to see the main feature of our Language Server: the validation of the DOT file.</p><p>But first we make sure that the validation is triggered after every change of each document.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">documents.onDidChangeContent((change) =&gt; {
    validateDotDocument(change.document);
});;</pre><p>We do just that by calling the validation when we receive a notification of a change. Since there is a line of communication between the server and the client we don&#8217;t have to answer right away. We first receive notification of the change and once the verification is complete we send back the errors.</p><p>The function <code>validateDotDocument</code> takes the changed document as argument and then compute errors. In this particular case we use a C# backend to perform the actual validation. So we just have to proxy the request through the Language Server and format the results for the client.</p><p>While this may be overkill for our example, it&#8217;s probably the best choice for big projects. If you want to easily use many linters and libraries, you are not going to mantain a specific version of each of these just for the Language Server. By integrating other services you can mantain a lean Language Server.</p><p>The validation is the best phase in which to integrate such services, because it&#8217;s not time sensitive. You can send back eventual errors at any time within a reasonable timeframe.</p><pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-highlight="2,5-6,17-25,28">function validateDotDocument(textDocument: TextDocument): void {
    let diagnostics: Diagnostic[] = []; 
        
    request.post({url:'http://localhost:3000/parse', body: textDocument.getText()}, function optionalCallback(err, httpResponse, body) {                
        let messages = JSON.parse(body).errors;
        names = JSON.parse(body).names;
        
        let lines = textDocument.getText().split(/\r?\n/g);
        let problems = 0;

        for (var i = 0; i &lt; messages.length &amp;&amp; problems &lt; maxNumberOfProblems; i++) {     
            problems++;
            
            if(messages[i].length == 0)
                messages[i].length = lines[i].length - messages[i].character;

            diagnostics.push({
                severity: DiagnosticSeverity.Error,
                range: {
                    start: { line: messages[i].line, character: messages[i].character},
                    end: { line: messages[i].line, character: messages[i].character + messages[i].length }
                },
                message: messages[i].message,
                source: 'ex'
            });         
        }
        // Send the computed diagnostics to VSCode.
        connection.sendDiagnostics({ uri: textDocument.uri, diagnostics });
    }); 
}</pre><p>On lines 5-6 we receive back both our errors and other values computed by our service (line 4). We take advantage of the validation to compute which are the names of nodes and graphs, that we store in a global variable. We are going to use these names later, to satisfy requests for hover information.</p><p>The rest of the marked lines shows the gist of the communication with the client:</p><ul><li>we gather the diagnostic messages</li><li>we setup them for easier use by the user</li><li>we send them to the client.</li></ul><p>We can choose the severity, for instance we can also simply communicate informations or warning. We must also choose a range for which the message apply, so that the user can deal with it. Sometimes this doesn&#8217;t always make sense or it&#8217;s possible, in such cases we choose as a range the rest of the line length, starting from the character that indicate the beginning of the error.</p><p>The editor will then take care of communicating the mistake to the user, usually by underlining the text. But nothing forbids the client to do something else, for instance if the client is a log manager, it could simply store the errore in some way.</p><div id="attachment_3249" style="width: 1020px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-3249" class="wp-image-3249 size-full" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201010%20709'%3E%3C/svg%3E" alt="How Visual Studio Code shows an error" width="1010" height="709" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1.png 1010w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-300x211.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-768x539.png 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-705x495.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-450x316.png 450w" data-lazy-sizes="(max-width: 1010px) 100vw, 1010px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1.png" /><noscript><img aria-describedby="caption-attachment-3249" class="wp-image-3249 size-full" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1.png" alt="How Visual Studio Code shows an error" width="1010" height="709" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1.png 1010w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-300x211.png 300w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-768x539.png 768w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-705x495.png 705w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Verifying-1-450x316.png 450w" sizes="(max-width: 1010px) 100vw, 1010px" /></noscript><p id="caption-attachment-3249" class="wp-caption-text">How Visual Studio Code shows an error</p></div><p>We are going to see the actual validation later, now we are going to see the last feature of our server, instead, the Hover Provider.</p><h3>A Simple Hover Provider</h3><p>An Hover Provider job is to give additional information on the text that the user is hovering on, such as the type of an object (ex. &#8220;class X&#8221;), documentation about it (ex. &#8220;The method Y is [&#8230;]) or the signature of a method.</p><p>For our language server we choose to show what are the elements that can be used in an edge declaration: node, graph or subgraph. To find that information ourselves we simply use a listener when we validate the DOT document on the service.</p><pre class="EnlighterJSRAW" data-enlighter-language="js">connection.onHover(({ textDocument, position }): Hover =&gt; {            
    for(var i = 0; i &lt; names.length; i++)
    {       
        if(names[i].line == position.line
           &amp;&amp; (names[i].start &lt;= position.character &amp;&amp; names[i].end &gt;= position.character) )
        {
            // we return an answer only if we find something
            // otherwise no hover information is given
            return {
                contents: names[i].text
            };
        }
    }   
});</pre><p>To communicate this information to the user, we search between the <strong>names </strong>that we have saved on the Languager Server. If we find one on the current position that the user is hovering on we tell the client, otherwise we show nothing.</p><div id="attachment_3250" style="width: 334px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-3250" class="size-full wp-image-3250" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20324%20176'%3E%3C/svg%3E" alt="VS Code Hover Information" width="324" height="176" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Hover.png 324w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Hover-300x163.png 300w" data-lazy-sizes="(max-width: 324px) 100vw, 324px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Hover.png" /><noscript><img aria-describedby="caption-attachment-3250" class="size-full wp-image-3250" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Hover.png" alt="VS Code Hover Information" width="324" height="176" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Hover.png 324w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/VSCode_Hover-300x163.png 300w" sizes="(max-width: 324px) 100vw, 324px" /></noscript><p id="caption-attachment-3250" class="wp-caption-text">VS Code Hover Information</p></div><h2>3. The C# Backend</h2><h3>Choosing One ANTLR Runtime Library</h3><p>Since we are creating a cross platform service we want to use the .NET Core Platform.</p><p>The new ANTLR 4.7.0 supports .NET Core, but at the moment the nuget package has a configuration problem and still does not work. Depending on when you read this the problem might have been solved, but now you have two choices: you compile the ANTLR Runtime for C# yourself, or you use the &#8220;C# optimized&#8221; version.</p><p>The problem is that this &#8220;C# optimized&#8221; version that supports .NET Core it&#8217;s still in beta, and the integration to automatically create the C# files from the grammar it&#8217;s still in the future. So the generate the C# files you have to download the latest beta nuget package for the <a href="https://www.nuget.org/packages/Antlr4.CodeGenerator/">ANTLR 4 Code Generator</a>. Then you have to decompress the .nupkg files, which is actually a zip file, and then run the included ANTLR4 program.</p><pre class="EnlighterJSRAW" data-enlighter-language="shell">/tools/antlr4-csharp-4.6.1-SNAPSHOT-complete.jar -package &lt;NAMESPACE-OF-YOUR-PROGRAM&gt; -o &lt;OUTPUT_DIR&gt; -Dlanguage=CSharp_v4_5 &lt;PATH-TO-GRAMMAR&gt;</pre><p>You can&#8217;t use the default ANTLR4 because it generates valid C# code, but that generated code is not compatible with the &#8220;C# optimized&#8221; runtime.</p><h3>The ANTLR Service</h3><p>We are going to rapidly skim through the structure of the C# ANTLR Service. It&#8217;s not that complicated, but if you don&#8217;t understand something you can read our <a href="https://tomassetti.me/antlr-mega-tutorial/">ANTLR Mega Tutorial</a>.</p><p>We setup ANTLR with a Listener, to gather the names to use for the hover information, and an ErrorListener, to collect any error in our DOT document. Then we create a simple ASP .NET Core app to communicate with the Language Server in TypeScript.</p><p>In <code>Program.cs (</code>not shown) we configure the program to listen on the port 3000, then we setup the main method, to comunicate with the server, in <code>Startup.cs</code>.</p><pre class="EnlighterJSRAW" data-enlighter-language="csharp">var routeBuilder = new RouteBuilder(app);                
            
routeBuilder.MapPost("parse", context =&gt;
{                
    [..]

    AntlrInputStream inputStream = new AntlrInputStream(text);
    DOTLexer lexer = new DOTLexer(inputStream);
    CommonTokenStream commonTokenStream = new CommonTokenStream(lexer);
    DOTParser parser = new DOTParser(commonTokenStream);  
    // the listener gathers the names for the hover information        
    DOTLanguageListener listener = new DOTLanguageListener();
    
    DOTErrorListener errorListener = new DOTErrorListener();
    DOTLexerErrorListener lexerErrorListener = new DOTLexerErrorListener();
    
    lexer.RemoveErrorListeners();
    lexer.AddErrorListener(lexerErrorListener);   
    parser.RemoveErrorListeners();
    parser.AddErrorListener(errorListener);
    
    GraphContext graph = parser.graph(); 

    ParseTreeWalker.Default.Walk(listener, graph);                

    [..]
});

var routes = routeBuilder.Build();

app.UseRouter(routes);</pre><p>We use a <code>RouteBuilder</code> to configure from which path we answer to. Since we only answer to one queston we could have directly answered from the root path, but this way is cleaner and it&#8217;s easier to add other services.</p><p>You can see that we actually use two ErrorListener(s), one each for the lexer and the parser. This way we can give better error information in the case of parser errors. The rest is the standard ANTLR program that use a Listener:</p><ul><li>we create the parser</li><li>we try to parse the main element (ie. <code>graph</code>)</li><li>we walk the resulting tree with our listener.</li></ul><p>The errors are found when we try to parse, on line 22, the names when we use the <code>LanguageListener</code>, on line 24.</p><p>The rest of the code simply prepare the JSON output that must be sent to the server of the Language Server Protocol.</p><h3>Finding The Names</h3><p>Let&#8217;s see where we find the names of the elements that we are providing for the hover information. This is achieved by listening to the firing of the <strong>id</strong> rule.</p><p>In our grammar the <strong>id</strong> rule is used to parse every name, attributed and value. So we have to distinguish between each case to find the ones we care about and categorize them.</p><pre class="EnlighterJSRAW" data-enlighter-language="csharp" data-enlighter-highlight="18">public override void ExitId(DOTParser.IdContext context)
{
    string name = "";
     
    if(context.Parent.GetType().Name == "Node_idContext")
        name = "(Node) ";
    
    if(context.Parent.GetType().Name == "SubgraphContext")
        name = "(Subgraph) ";

    if(context.Parent.GetType().Name == "GraphContext")                
        name = "(Graph) ";                 

    if(!String.IsNullOrEmpty(name))
    {       
        Names.Add(new Name() {
            Text = name + context.GetText(),
            Line = context.Stop.Line - 1,
            Start =  context.Start.Column,
            End = context.Start.Column + context.GetText().Length
        });
    }
}</pre><p>We do just that by looking at the type of the parent of the <code>Id</code> node that has fired the method. On line 18 we subtract 1 to the line because ANTLR count lines as humans do, starting from 1, while Visual Studio Code count as a developer, starting by 0.</p><h2>Summary</h2><p>In this tutorial we have seen how to create a client of a Language Server for Visual Studio Code, a server with Visual Studio Code and a backend in C#.</p><p>We have seen how easily you can add features to your Language Server and one way to integrate it with another service that you already are using. This way you <strong>can create your language server as lightweight as you want</strong>. You can make it useful from day one and improve it along the way.</p><p>Of course we have leveraged a few things ready to be used:</p><ul><li>an ANTLR grammar for our language</li><li>a client and a server implementation of the Language Server Protocol</li></ul><p>What is amazing is that with one server you can leverage all the clients, even the one you don&#8217;t write yourself.</p><p>If you need more inspiration you can find <a href="https://code.visualstudio.com/docs/extensions/example-language-server">additional</a> <a href="https://code.visualstudio.com/docs/extensions/samples">examples</a> and <a href="https://code.visualstudio.com/docs/extensionAPI/language-support">informations</a> on the Visual Studio Code documentation. There is also the description of the <a href="https://github.com/Microsoft/language-server-protocol/blob/master/protocol.md">Language Server Protoco</a>l itself, if you need to implement everything from scratch.</p><div class="ttr_end"></div><span id="tve_leads_end_content" style="display: block; visibility: hidden; border: 1px solid transparent;"></span></div><footer class="entry-footer"><span class="blog-tags minor-meta"><strong>Tags:</strong><span> <a href="https://tomassetti.me/tag/language-server-protocol/" rel="tag">language server protocol</a></span></span></footer><div class='post_delimiter'></div></div><div class='post_author_timeline'></div><span class='hidden'> <span class='av-structured-data' itemprop="image" itemscope="itemscope" itemtype="https://schema.org/ImageObject" itemprop='image'> <span itemprop='url'>https://tomassetti.me/wp-content/uploads/2017/04/A-Language-Server-For-DOT-With-Visual-Studio-Code.jpg</span> <span itemprop='height'>512</span> <span itemprop='width'>1024</span> </span><span class='av-structured-data' itemprop="publisher" itemtype="https://schema.org/Organization" itemscope="itemscope"> <span itemprop='name'>Gabriele Tomassetti</span> <span itemprop='logo' itemscope itemtype='https://schema.org/ImageObject'> <span itemprop='url'>https://tomassetti.me/wp-content/uploads/2017/07/federico-tomassetti-software-architect-300.png</span> </span> </span><span class='av-structured-data' itemprop="author" itemscope="itemscope" itemtype="https://schema.org/Person"><span itemprop='name'>Gabriele Tomassetti</span></span><span class='av-structured-data' itemprop="datePublished" datetime="2017-04-05T11:37:18+02:00">2017-04-05 11:37:18</span><span class='av-structured-data' itemprop="dateModified" itemtype="https://schema.org/dateModified">2020-05-11 17:59:24</span><span class='av-structured-data' itemprop="mainEntityOfPage" itemtype="https://schema.org/mainEntityOfPage"><span itemprop='name'>Language Server Protocol: A Language Server For DOT With Visual Studio Code</span></span></span></article><div class='small'></div><div class="related_posts"><h5 class='related_title'>You might also like</h5><div class='related_entries_container '><div class='av_one_eighth no_margin alpha relThumb relThumb1 relThumbOdd post-format-standard related_column'> <a href='https://tomassetti.me/difference-between-compiler-interpreter/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="The Difference Between a Compiler and an Interpreter"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="The difference between a compiler and an interpreter" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-180x180.jpg" class="attachment-square size-square wp-post-image" alt="The difference between a compiler and an interpreter" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/05/The-difference-between-a-compiler-and-an-interpreter-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin relThumb relThumb2 relThumbEven post-format-standard related_column'> <a href='https://tomassetti.me/jariko-an-rpg-interpreter-in-kotlin/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="JaRIKo, an RPG Interpreter in Kotlin"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-180x180.jpg" class="attachment-square size-square wp-post-image" alt="" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2020/03/JaRIKo-an-RPG-Interpreter-in-Kotlin-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin relThumb relThumb3 relThumbOdd post-format-standard related_column'> <a href='https://tomassetti.me/what-is-the-language-server-protocol/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="Why You Should Know the Language Server Protocol"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="Why You Should Know the Language Server Protocol" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-180x180.jpg" class="attachment-square size-square wp-post-image" alt="Why You Should Know the Language Server Protocol" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/02/Why-You-Should-Know-the-Language-Server-Protocol-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin relThumb relThumb4 relThumbEven post-format-standard related_column'> <a href='https://tomassetti.me/getting-started-with-roslyn-transforming-c-code/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="Getting started with Roslyn: transforming C# code"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-180x180.jpg" class="attachment-square size-square wp-post-image" alt="" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/10/Getting-started-with-Roslyn-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin relThumb relThumb5 relThumbOdd post-format-standard related_column'> <a href='https://tomassetti.me/antlr-mega-tutorial/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="The ANTLR Mega Tutorial"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="ANTLR Mega Tutorial" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-180x180.jpg" class="attachment-square size-square wp-post-image" alt="ANTLR Mega Tutorial" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin relThumb relThumb6 relThumbEven post-format-standard related_column'> <a href='https://tomassetti.me/introduction-to-webassembly/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="Understand WebAssembly: Why It Will Change the Web"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="Understand WebAssembly" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-180x180.jpg" class="attachment-square size-square wp-post-image" alt="Understand WebAssembly" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/12/Understand-WebAssembly-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin relThumb relThumb7 relThumbOdd post-format-standard related_column'> <a href='https://tomassetti.me/getting-started-with-antlr-building-a-simple-expression-language/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="Getting started with ANTLR: building a simple expression language"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-180x180.jpg" class="attachment-square size-square wp-post-image" alt="" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2016/07/Getting-started-with-ANTLR_-building-simple-language-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div><div class='av_one_eighth no_margin omega relThumb relThumb8 relThumbEven post-format-standard related_column'> <a href='https://tomassetti.me/resources-create-programming-languages/' class='relThumWrap noLightbox'> <span class='related_image_wrap' data-avia-related-tooltip="68 Resources To Help You To Create Programming Languages"><img width="180" height="180" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20180%20180'%3E%3C/svg%3E" class="attachment-square size-square wp-post-image" alt="68 Resources To Help You To Create Programming Languages" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-450x450.jpg 450w" data-lazy-sizes="(max-width: 180px) 100vw, 180px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-180x180.jpg" /><noscript><img width="180" height="180" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-180x180.jpg" class="attachment-square size-square wp-post-image" alt="68 Resources To Help You To Create Programming Languages" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-450x450.jpg 450w" sizes="(max-width: 180px) 100vw, 180px" /></noscript> <span class='related-format-icon '><span class='related-format-icon-inner' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span></span> </span> </a></div></div></div><div class='comment-entry post-entry'></div></main><aside class='sidebar sidebar_right alpha units' role="complementary" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"><div class='inner_sidebar extralight-border'><section id="custom_html-2" class="widget_text widget clearfix widget_custom_html"><h3 class="widgettitle">Strumenta &#8211; Consulting</h3><div class="textwidget custom-html-widget">If you need help designing and developing DSLs, languages, parsers, compilers, interpreters, and editors you can check the <a href="https://strumenta.com/services" style="text-decoration: underline;">services page</a> of the Consulting studio we founded: <a href="https://strumenta.com">Strumenta</a>. <a href="https://strumenta.com"><img style="display: block;margin: 10px 30px 0;width:70%" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Strumenta Logo" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2018/03/SRUMENTA-ESTESO-320x132.png"><noscript><img style="display: block;margin: 10px 30px 0;width:70%" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2018/03/SRUMENTA-ESTESO-320x132.png" alt="Strumenta Logo"></noscript></a></div><span class="seperator extralight-border"></span></section><section id="categories-7" class="widget clearfix widget_categories"><h3 class="widgettitle">Blog Categories</h3><ul><li class="cat-item cat-item-57"><a href="https://tomassetti.me/category/language-engineering/antlr/" title="Tutorials, news and informations on the parser generator ANTLR">ANTLR</a> (17)</li><li class="cat-item cat-item-173"><a href="https://tomassetti.me/category/application-modernization/">Application modernization</a> (2)</li><li class="cat-item cat-item-30"><a href="https://tomassetti.me/category/static-analysis/" title="Articles about extracting data from code, analyze it and programmatically transform it. In other words we talk about static analysis, automated refactoring, and code generation.">Code processing</a> (24)</li><li class="cat-item cat-item-68"><a href="https://tomassetti.me/category/consulting/" title="My experience about consulting and freelancing">Consulting</a> (14)</li><li class="cat-item cat-item-166"><a href="https://tomassetti.me/category/language-engineering/create-a-programming-language/">Create a programming language</a> (1)</li><li class="cat-item cat-item-38"><a href="https://tomassetti.me/category/language-engineering/domain-specific-languages/" title="News, guides, tutorials and the bigger picture of creating domain specific languages">Domain specific languages</a> (16)</li><li class="cat-item cat-item-172"><a href="https://tomassetti.me/category/language-engineering/editors/">Editors</a> (1)</li><li class="cat-item cat-item-54"><a href="https://tomassetti.me/category/language-engineering/jetbrains-mps/" title="Informations and tutorials on the language workbench Jetbrains MPS">Jetbrains MPS</a> (11)</li><li class="cat-item cat-item-52"><a href="https://tomassetti.me/category/language-engineering/language-design/" title="Strategies, tips and tutorials on designing programming languages">Language design</a> (13)</li><li class="cat-item cat-item-60"><a href="https://tomassetti.me/category/language-engineering/" title="The science, tools, strategies, patterns and tools behind the creation and processing of languages">Language Engineering</a> (33)</li><li class="cat-item cat-item-1"><a href="https://tomassetti.me/category/miscellany/" title="Reviews, ideas, tip, opinions, etc. on all aspects of software development">Miscellany</a> (5)</li><li class="cat-item cat-item-5"><a href="https://tomassetti.me/category/language-engineering/mdd/" title="Articles on creating software working on domains models">Model driven development</a> (4)</li><li class="cat-item cat-item-171"><a href="https://tomassetti.me/category/natural-language-processing/">Natural Language Processing</a> (1)</li><li class="cat-item cat-item-70"><a href="https://tomassetti.me/category/random-stuff/" title="Everything that is not related to software development: ideas on natural languages, countries I have lived in, my life, stuff that make me curious. All sort of interesting things.">Non software development</a> (4)</li><li class="cat-item cat-item-23"><a href="https://tomassetti.me/category/open-source/" title="Ideas and tips on how to make open source project successful and my open source projects">Open-source</a> (8)</li><li class="cat-item cat-item-39"><a href="https://tomassetti.me/category/language-engineering/parsing/" title="Tutorials and issues on all aspects of creating software to analyse code">Parsing</a> (22)</li><li class="cat-item cat-item-17"><a href="https://tomassetti.me/category/research/" title="Research Papers, conferences and challenges at the forefront of Language Engineering">Research</a> (4)</li><li class="cat-item cat-item-4"><a href="https://tomassetti.me/category/development/" title="Everything related to software development that every developer could find useful">Software Development</a> (16)</li><li class="cat-item cat-item-35"><a href="https://tomassetti.me/category/software-engineering/" title="Methods and processes of Software Engineering: how to create beautiful software">Software Engineering</a> (13)</li><li class="cat-item cat-item-44"><a href="https://tomassetti.me/category/turin-programming-language/" title="The creation of the Turin Programmin Language: examples, problems, solutions and strategies.">Turin Programming Language</a> (4)</li><li class="cat-item cat-item-63"><a href="https://tomassetti.me/category/language-engineering/whole-platform/" title="Informations and opinions about the Whole Platform">Whole Platform</a> (2)</li><li class="cat-item cat-item-56"><a href="https://tomassetti.me/category/language-engineering/xtext/" title="News and tips on Xtext">Xtext</a> (3)</li></ul> <span class="seperator extralight-border"></span></section></div></aside></div></div><div class='container_wrap footer_color' id='footer'><div class='container'><div class='flex_column av_one_fourth first el_before_av_one_fourth'><section id="nav_menu-3" class="widget clearfix widget_nav_menu"><h3 class="widgettitle">Menu</h3><div class="menu-tomassetti_footer-container"><ul id="menu-tomassetti_footer" class="menu"><li id="menu-item-2582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2582"><a href="https://tomassetti.me/about-me/">About me</a></li><li id="menu-item-2579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2579"><a href="https://tomassetti.me/how-i-work/">How I work</a></li><li id="menu-item-5981" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5981"><a href="https://strumenta.com/services/">Language Engineering Services</a><ul class="sub-menu"><li id="menu-item-5092" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5092"><a href="https://strumenta.com/antlr-consulting/">ANTLR Consulting</a></li><li id="menu-item-5984" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5984"><a href="https://strumenta.com/jetbrains-mps-consulting/">Jetbrains MPS Consulting</a></li></ul></li><li id="menu-item-5961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5961"><a href="https://strumenta.com/contact-us/">Contact</a></li><li id="menu-item-2585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2585"><a href="https://ie.linkedin.com/in/federicotomassetti">LinkedIn</a></li></ul></div><span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fourth el_after_av_one_fourth el_before_av_one_fourth '><section id="categories-5" class="widget clearfix widget_categories"><h3 class="widgettitle">Blog Categories</h3><ul><li class="cat-item cat-item-57"><a href="https://tomassetti.me/category/language-engineering/antlr/" title="Tutorials, news and informations on the parser generator ANTLR">ANTLR</a> (17)</li><li class="cat-item cat-item-173"><a href="https://tomassetti.me/category/application-modernization/">Application modernization</a> (2)</li><li class="cat-item cat-item-30"><a href="https://tomassetti.me/category/static-analysis/" title="Articles about extracting data from code, analyze it and programmatically transform it. In other words we talk about static analysis, automated refactoring, and code generation.">Code processing</a> (24)</li><li class="cat-item cat-item-68"><a href="https://tomassetti.me/category/consulting/" title="My experience about consulting and freelancing">Consulting</a> (14)</li><li class="cat-item cat-item-166"><a href="https://tomassetti.me/category/language-engineering/create-a-programming-language/">Create a programming language</a> (1)</li><li class="cat-item cat-item-38"><a href="https://tomassetti.me/category/language-engineering/domain-specific-languages/" title="News, guides, tutorials and the bigger picture of creating domain specific languages">Domain specific languages</a> (16)</li><li class="cat-item cat-item-172"><a href="https://tomassetti.me/category/language-engineering/editors/">Editors</a> (1)</li><li class="cat-item cat-item-54"><a href="https://tomassetti.me/category/language-engineering/jetbrains-mps/" title="Informations and tutorials on the language workbench Jetbrains MPS">Jetbrains MPS</a> (11)</li><li class="cat-item cat-item-52"><a href="https://tomassetti.me/category/language-engineering/language-design/" title="Strategies, tips and tutorials on designing programming languages">Language design</a> (13)</li><li class="cat-item cat-item-60"><a href="https://tomassetti.me/category/language-engineering/" title="The science, tools, strategies, patterns and tools behind the creation and processing of languages">Language Engineering</a> (33)</li><li class="cat-item cat-item-1"><a href="https://tomassetti.me/category/miscellany/" title="Reviews, ideas, tip, opinions, etc. on all aspects of software development">Miscellany</a> (5)</li><li class="cat-item cat-item-5"><a href="https://tomassetti.me/category/language-engineering/mdd/" title="Articles on creating software working on domains models">Model driven development</a> (4)</li><li class="cat-item cat-item-171"><a href="https://tomassetti.me/category/natural-language-processing/">Natural Language Processing</a> (1)</li><li class="cat-item cat-item-70"><a href="https://tomassetti.me/category/random-stuff/" title="Everything that is not related to software development: ideas on natural languages, countries I have lived in, my life, stuff that make me curious. All sort of interesting things.">Non software development</a> (4)</li><li class="cat-item cat-item-23"><a href="https://tomassetti.me/category/open-source/" title="Ideas and tips on how to make open source project successful and my open source projects">Open-source</a> (8)</li><li class="cat-item cat-item-39"><a href="https://tomassetti.me/category/language-engineering/parsing/" title="Tutorials and issues on all aspects of creating software to analyse code">Parsing</a> (22)</li><li class="cat-item cat-item-17"><a href="https://tomassetti.me/category/research/" title="Research Papers, conferences and challenges at the forefront of Language Engineering">Research</a> (4)</li><li class="cat-item cat-item-4"><a href="https://tomassetti.me/category/development/" title="Everything related to software development that every developer could find useful">Software Development</a> (16)</li><li class="cat-item cat-item-35"><a href="https://tomassetti.me/category/software-engineering/" title="Methods and processes of Software Engineering: how to create beautiful software">Software Engineering</a> (13)</li><li class="cat-item cat-item-44"><a href="https://tomassetti.me/category/turin-programming-language/" title="The creation of the Turin Programmin Language: examples, problems, solutions and strategies.">Turin Programming Language</a> (4)</li><li class="cat-item cat-item-63"><a href="https://tomassetti.me/category/language-engineering/whole-platform/" title="Informations and opinions about the Whole Platform">Whole Platform</a> (2)</li><li class="cat-item cat-item-56"><a href="https://tomassetti.me/category/language-engineering/xtext/" title="News and tips on Xtext">Xtext</a> (3)</li></ul> <span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fourth el_after_av_one_fourth el_before_av_one_fourth '><section id="tag_cloud-3" class="widget clearfix widget_tag_cloud"><h3 class="widgettitle">Tags</h3><div class="tagcloud"><a href="https://tomassetti.me/tag/automation/" class="tag-cloud-link tag-link-73 tag-link-position-1" style="font-size: 10.964705882353pt;" aria-label="Automation (2 items)">Automation</a> <a href="https://tomassetti.me/tag/c/" class="tag-cloud-link tag-link-91 tag-link-position-2" style="font-size: 20.847058823529pt;" aria-label="C# (11 items)">C#</a> <a href="https://tomassetti.me/tag/clojure/" class="tag-cloud-link tag-link-80 tag-link-position-3" style="font-size: 12.941176470588pt;" aria-label="Clojure (3 items)">Clojure</a> <a href="https://tomassetti.me/tag/code-generation/" class="tag-cloud-link tag-link-156 tag-link-position-4" style="font-size: 10.964705882353pt;" aria-label="code generation (2 items)">code generation</a> <a href="https://tomassetti.me/tag/dsl/" class="tag-cloud-link tag-link-111 tag-link-position-5" style="font-size: 14.588235294118pt;" aria-label="dsl (4 items)">dsl</a> <a href="https://tomassetti.me/tag/effectivejava/" class="tag-cloud-link tag-link-135 tag-link-position-6" style="font-size: 12.941176470588pt;" aria-label="effectivejava (3 items)">effectivejava</a> <a href="https://tomassetti.me/tag/formats/" class="tag-cloud-link tag-link-146 tag-link-position-7" style="font-size: 10.964705882353pt;" aria-label="formats (2 items)">formats</a> <a href="https://tomassetti.me/tag/frege/" class="tag-cloud-link tag-link-74 tag-link-position-8" style="font-size: 10.964705882353pt;" aria-label="Frege (2 items)">Frege</a> <a href="https://tomassetti.me/tag/functional-programming/" class="tag-cloud-link tag-link-86 tag-link-position-9" style="font-size: 10.964705882353pt;" aria-label="Functional programming (2 items)">Functional programming</a> <a href="https://tomassetti.me/tag/guide/" class="tag-cloud-link tag-link-147 tag-link-position-10" style="font-size: 12.941176470588pt;" aria-label="guide (3 items)">guide</a> <a href="https://tomassetti.me/tag/haskell/" class="tag-cloud-link tag-link-75 tag-link-position-11" style="font-size: 12.941176470588pt;" aria-label="Haskell (3 items)">Haskell</a> <a href="https://tomassetti.me/tag/icse/" class="tag-cloud-link tag-link-18 tag-link-position-12" style="font-size: 8pt;" aria-label="icse (1 item)">icse</a> <a href="https://tomassetti.me/tag/image-processing/" class="tag-cloud-link tag-link-72 tag-link-position-13" style="font-size: 8pt;" aria-label="Image processing (1 item)">Image processing</a> <a href="https://tomassetti.me/tag/interpreters/" class="tag-cloud-link tag-link-149 tag-link-position-14" style="font-size: 10.964705882353pt;" aria-label="interpreters (2 items)">interpreters</a> <a href="https://tomassetti.me/tag/interview/" class="tag-cloud-link tag-link-71 tag-link-position-15" style="font-size: 22pt;" aria-label="Interview (13 items)">Interview</a> <a href="https://tomassetti.me/tag/java/" class="tag-cloud-link tag-link-24 tag-link-position-16" style="font-size: 17.882352941176pt;" aria-label="java (7 items)">java</a> <a href="https://tomassetti.me/tag/javaparser/" class="tag-cloud-link tag-link-83 tag-link-position-17" style="font-size: 17.058823529412pt;" aria-label="JavaParser (6 items)">JavaParser</a> <a href="https://tomassetti.me/tag/javascript/" class="tag-cloud-link tag-link-89 tag-link-position-18" style="font-size: 14.588235294118pt;" aria-label="JavaScript (4 items)">JavaScript</a> <a href="https://tomassetti.me/tag/javasymbolsolver/" class="tag-cloud-link tag-link-81 tag-link-position-19" style="font-size: 8pt;" aria-label="JavaSymbolSolver (1 item)">JavaSymbolSolver</a> <a href="https://tomassetti.me/tag/jetbrains-mps/" class="tag-cloud-link tag-link-13 tag-link-position-20" style="font-size: 14.588235294118pt;" aria-label="jetbrains mps (4 items)">jetbrains mps</a> <a href="https://tomassetti.me/tag/kotlin/" class="tag-cloud-link tag-link-90 tag-link-position-21" style="font-size: 14.588235294118pt;" aria-label="Kotlin (4 items)">Kotlin</a> <a href="https://tomassetti.me/tag/language-integration/" class="tag-cloud-link tag-link-16 tag-link-position-22" style="font-size: 10.964705882353pt;" aria-label="language integration (2 items)">language integration</a> <a href="https://tomassetti.me/tag/language-server-protocol/" class="tag-cloud-link tag-link-100 tag-link-position-23" style="font-size: 12.941176470588pt;" aria-label="language server protocol (3 items)">language server protocol</a> <a href="https://tomassetti.me/tag/language-worbenches/" class="tag-cloud-link tag-link-19 tag-link-position-24" style="font-size: 8pt;" aria-label="language worbenches (1 item)">language worbenches</a> <a href="https://tomassetti.me/tag/libav/" class="tag-cloud-link tag-link-84 tag-link-position-25" style="font-size: 10.964705882353pt;" aria-label="Libav (2 items)">Libav</a> <a href="https://tomassetti.me/tag/machine-learning/" class="tag-cloud-link tag-link-121 tag-link-position-26" style="font-size: 10.964705882353pt;" aria-label="machine learning (2 items)">machine learning</a> <a href="https://tomassetti.me/tag/mbeddr/" class="tag-cloud-link tag-link-48 tag-link-position-27" style="font-size: 8pt;" aria-label="mbeddr (1 item)">mbeddr</a> <a href="https://tomassetti.me/tag/mise/" class="tag-cloud-link tag-link-20 tag-link-position-28" style="font-size: 8pt;" aria-label="mise (1 item)">mise</a> <a href="https://tomassetti.me/tag/natural-language/" class="tag-cloud-link tag-link-113 tag-link-position-29" style="font-size: 10.964705882353pt;" aria-label="natural language (2 items)">natural language</a> <a href="https://tomassetti.me/tag/nlp/" class="tag-cloud-link tag-link-140 tag-link-position-30" style="font-size: 10.964705882353pt;" aria-label="nlp (2 items)">nlp</a> <a href="https://tomassetti.me/tag/open-source/" class="tag-cloud-link tag-link-82 tag-link-position-31" style="font-size: 10.964705882353pt;" aria-label="Open-source (2 items)">Open-source</a> <a href="https://tomassetti.me/tag/opensource/" class="tag-cloud-link tag-link-157 tag-link-position-32" style="font-size: 10.964705882353pt;" aria-label="opensource (2 items)">opensource</a> <a href="https://tomassetti.me/tag/programming-languages/" class="tag-cloud-link tag-link-123 tag-link-position-33" style="font-size: 14.588235294118pt;" aria-label="programming languages (4 items)">programming languages</a> <a href="https://tomassetti.me/tag/python/" class="tag-cloud-link tag-link-78 tag-link-position-34" style="font-size: 17.882352941176pt;" aria-label="Python (7 items)">Python</a> <a href="https://tomassetti.me/tag/refactoring/" class="tag-cloud-link tag-link-116 tag-link-position-35" style="font-size: 12.941176470588pt;" aria-label="refactoring (3 items)">refactoring</a> <a href="https://tomassetti.me/tag/review/" class="tag-cloud-link tag-link-102 tag-link-position-36" style="font-size: 10.964705882353pt;" aria-label="review (2 items)">review</a> <a href="https://tomassetti.me/tag/roslyn/" class="tag-cloud-link tag-link-99 tag-link-position-37" style="font-size: 14.588235294118pt;" aria-label="Roslyn (4 items)">Roslyn</a> <a href="https://tomassetti.me/tag/sparkweb/" class="tag-cloud-link tag-link-85 tag-link-position-38" style="font-size: 14.588235294118pt;" aria-label="SparkWeb (4 items)">SparkWeb</a> <a href="https://tomassetti.me/tag/static-analysis/" class="tag-cloud-link tag-link-104 tag-link-position-39" style="font-size: 10.964705882353pt;" aria-label="static-analysis (2 items)">static-analysis</a> <a href="https://tomassetti.me/tag/testing/" class="tag-cloud-link tag-link-25 tag-link-position-40" style="font-size: 8pt;" aria-label="testing (1 item)">testing</a> <a href="https://tomassetti.me/tag/tools/" class="tag-cloud-link tag-link-107 tag-link-position-41" style="font-size: 12.941176470588pt;" aria-label="tools (3 items)">tools</a> <a href="https://tomassetti.me/tag/tripadvisor/" class="tag-cloud-link tag-link-120 tag-link-position-42" style="font-size: 12.941176470588pt;" aria-label="TripAdvisor (3 items)">TripAdvisor</a> <a href="https://tomassetti.me/tag/tutorial/" class="tag-cloud-link tag-link-134 tag-link-position-43" style="font-size: 17.882352941176pt;" aria-label="tutorial (7 items)">tutorial</a> <a href="https://tomassetti.me/tag/web/" class="tag-cloud-link tag-link-98 tag-link-position-44" style="font-size: 10.964705882353pt;" aria-label="web (2 items)">web</a> <a href="https://tomassetti.me/tag/webassembly/" class="tag-cloud-link tag-link-105 tag-link-position-45" style="font-size: 10.964705882353pt;" aria-label="WebAssembly (2 items)">WebAssembly</a></div> <span class="seperator extralight-border"></span></section></div><div class='flex_column av_one_fourth el_after_av_one_fourth el_before_av_one_fourth '><section id="custom_html-5" class="widget_text widget clearfix widget_custom_html"><h3 class="widgettitle">Don&#8217;t miss the next updates!</h3><div class="textwidget custom-html-widget"><span style="display:none" class="tl-placeholder-f-type-shortcode_4566"></span></div><span class="seperator extralight-border"></span></section></div></div></div><footer class='container_wrap socket_color' id='socket' role="contentinfo" itemscope="itemscope" itemtype="https://schema.org/WPFooter"><div class='container'> <span class='copyright'>© 2018 Strumenta | <a href="https://strumenta.com/privacy-policy/">Privacy Policy of Strumenta Websites</a></span><ul class='noLightbox social_bookmarks icon_count_4'><li class='social_bookmarks_twitter av-social-link-twitter social_icon_1'><a target="_blank" aria-label="Link to Twitter" href="https://twitter.com/ftomasse" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Twitter'><span class='avia_hidden_link_text'>Twitter</span></a></li><li class='social_bookmarks_linkedin av-social-link-linkedin social_icon_2'><a target="_blank" aria-label="Link to Linkedin" href="https://ie.linkedin.com/in/federicotomassetti" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Linkedin'><span class='avia_hidden_link_text'>Linkedin</span></a></li><li class='social_bookmarks_mail av-social-link-mail social_icon_3'><a aria-label="Link to Mail" href="/cdn-cgi/l/email-protection#80e6e5e4e5f2e9e3efc0f4efede1f3f3e5f4f4e9aeede5" aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Mail'><span class='avia_hidden_link_text'>Mail</span></a></li><li class='social_bookmarks_rss av-social-link-rss social_icon_4'><a aria-label="Link to Rss this site" href='https://tomassetti.me/feed/' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello' title='Rss'><span class='avia_hidden_link_text'>Rss</span></a></li></ul></div></footer></div> <a class='avia-post-nav avia-post-prev with-image' href='https://tomassetti.me/roadmapping-service-language-engineering/'> <span class='label iconfont' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span> <span class='entry-info-wrap'> <span class='entry-info'> <span class='entry-title'>Why to Offer a Roadmapping Service for Language Engineering?</span> <span class='entry-image'><img width="80" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Why to offer a roadmapping service for Language Engineering_" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-450x450.jpg 450w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-80x80.jpg" /><noscript><img width="80" height="80" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-80x80.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Why to offer a roadmapping service for Language Engineering_" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/Why-to-offer-a-roadmapping-service-for-Language-Engineering_-450x450.jpg 450w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></span> </span> </span></a><a class='avia-post-nav avia-post-next with-image' href='https://tomassetti.me/resources-create-programming-languages/'> <span class='label iconfont' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'></span> <span class='entry-info-wrap'> <span class='entry-info'> <span class='entry-image'><img width="80" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" class="attachment-thumbnail size-thumbnail wp-post-image" alt="68 Resources To Help You To Create Programming Languages" data-lazy-srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-450x450.jpg 450w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-80x80.jpg" /><noscript><img width="80" height="80" src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-80x80.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="68 Resources To Help You To Create Programming Languages" srcset="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-80x80.jpg 80w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-36x36.jpg 36w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-180x180.jpg 180w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-120x120.jpg 120w, https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages-450x450.jpg 450w" sizes="(max-width: 80px) 100vw, 80px" /></noscript></span> <span class='entry-title'>68 Resources To Help You To Create Programming Languages</span> </span> </span></a></div> <a href='#top' title='Scroll to top' id='scroll-top-link' aria-hidden='true' data-av_icon='' data-av_iconfont='entypo-fontello'><span class="avia_hidden_link_text">Scroll to top</span></a><div id="fb-root"></div><div class='avia-cookie-consent cookiebar-hidden avia-cookiemessage-bottom-left'><div class='container'><p class="avia_cookie_text">This site uses cookies. By continuing to browse the site, you are agreeing to our use of cookies.</p> <a href='https://strumenta.com/privacy-policy' class='avia-button avia-cookie-consent-button avia-cookie-consent-button-1 av-extra-cookie-btn'>Privacy Policy of Strumenta Websites</a><a href='#' class='avia-button avia-cookie-consent-button avia-cookie-consent-button-2 avia-cookie-close-bar ' data-contents='a6fe7a635a3ae90b600d28d9abace894'>OK</a></div></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>function aggiungiAttributiAnalytics() {
        var fakeurl = document.URL;
        if(document.location.search.length > 0)
        {
            let params = new URLSearchParams(document.location.search.substring(1));    
            fakeurl = params.get("da");
        }
	ga('send', {
		hitType: 'event',
		eventCategory: 'Link',
		eventAction: 'click',
		eventLabel: this.textContent,
		dimension1: fakeurl,
		dimension2: this.href,
		transport: 'beacon'
	});
}

// aggiungi attributi ai link per tracciamento
for (var ls = document.getElementsByTagName("a"), numLinks = ls.length, i=0; i<numLinks; i++){    
        ls[i].addEventListener("click", aggiungiAttributiAnalytics, false);
	ls[i].addEventListener("auxclick", aggiungiAttributiAnalytics, false);
	ls[i].addEventListener("contextmenu", aggiungiAttributiAnalytics, false);
}

for (var lsb = document.getElementsByTagName("button"), numLinks = lsb.length, i=0; i<numLinks; i++){    
        lsb[i].addEventListener("click", aggiungiAttributiAnalytics, false);
	lsb[i].addEventListener("auxclick", aggiungiAttributiAnalytics, false);
	lsb[i].addEventListener("contextmenu", aggiungiAttributiAnalytics, false);
}

function track_checkout(price, item) {
    fbq('track', 'InitiateCheckout', {
      content_name: item,
      value: price,
      currency: 'USD'
    });
}
// aggiungi tracciamento delle riproduzioni audio
jQuery("#amazon-ai-player").on("play", function (e) {
    ga('send', {
        hitType: 'event',
        eventCategory: 'Audio',
        eventAction: 'play',
        eventLabel: document.title.substr(0, document.title.search(" - Federico Tomassetti"))
    });
});

// Find all YouTube and Vimeo videos
var allVideos = jQuery("iframe[src*='//player.vimeo.com'], iframe[src*='//www.youtube.com']"),

    // The element that is fluid width
    fluidEl = jQuery("body");

// Figure out and save aspect ratio for each video
allVideos.each(function() {
  jQuery(this)
    .data('aspectRatio', this.height / this.width)

    // and remove the hard coded width/height
    .removeAttr('height')
    .removeAttr('width');

});

// When the window is resized
jQuery(window).resize(function() {

  var newWidth = fluidEl.width();

  // Resize all videos according to their own aspect ratio
  allVideos.each(function() {

    var el = jQuery(this);
    el
      .width(newWidth)
      .height(newWidth * el.data('aspectRatio'));

  });

// Kick off one resize to fix all videos on page load
}).resize();</script> <div id="sb_super_bar" class="orange"><div class="sbprogress-container"><span class="sbprogress-bar"></span></div><div id="sb_main_bar"><div class="sb_text-size"> <a href="https://tomassetti.me/category/language-engineering/">Language Engineering</a></div><div class="sb_post-data"><h2> Language Server Protocol: A Language Server For DOT With Visual Studio Code</h2> <span class="sb_author">by Gabriele Tomassetti</span> <span class="sb_ttr">time to read: 18 min</span></div><div class="sb_prev-next-posts"> <a href="https://tomassetti.me/resources-create-programming-languages/"><i class="sbicn-right-open-1"></i></a><div class="sb_next_post"><div class="sb_next_post_image"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages.jpg"><noscript><img src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/04/68-Resources-To-Help-You-To-Create-Programming-Languages.jpg" alt=""></noscript></div><div class="sb_next_post_info"> <span class="sb_title"> <span class="sb_category"> Language design </span> <span class="sb_tcategory"> 68 Resources To Help You To Create Programming Lan… </span> </span></div></div> <a href="https://tomassetti.me/antlr-mega-tutorial/"><i class="sbicn-left-open-1"></i></a><div class="sb_next_post"><div class="sb_next_post_image"> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" data-lazy-src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial.jpg"><noscript><img src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/uploads/2017/03/ANTLR-Mega-Tutorial.jpg" alt=""></noscript></div><div class="sb_next_post_info"> <span class="sb_title"> <span class="sb_category"> ANTLR </span> <span class="sb_tcategory"> The ANTLR Mega Tutorial </span> </span></div></div></div><ul class="sb_share "><li class="sbfacebook"> <a href="#" title="Share on Facebook" class="sbsoc-fb" target="_blank"><i class="sbicn-facebook"></i> </a></li><li class="sbtwitter"> <a href="#" data-via="" data-title="Language Server Protocol: A Language Server For DOT With Visual Studio Code" title="Share on Twitter" class="sbsoc-tw" target="_blank"><i class="sbicn-twitter"></i> </a></li><li class="sblinkedin"> <a href="#" title="Share on Linkedin" class="sbsoc-linked" target="_blank"><i class="sbicn-linkedin"></i> </a></li></ul></div></div> <script type='text/javascript'>/* <![CDATA[ */ var avia_framework_globals = avia_framework_globals || {};
    avia_framework_globals.frameworkUrl = 'https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/framework/';
    avia_framework_globals.installedAt = 'https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/themes/enfold/';
    avia_framework_globals.ajaxurl = 'https://tomassetti.me/wp-admin/admin-ajax.php'; /* ]]> */</script> <span style="display:none" class="tl-placeholder-f-type-slide_in"></span><script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/avia-93d6ec4cf60db7cca150d7e0ad8aa2f7.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/shortcodes-a99528795d03cc2b63fdc255d187a939.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/contact/contact-f1cc2fdbf0ca4a2c3a4d22b591d5b71c.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/countdown/countdown-692361e31cf26adda95ef748d233cac2.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/gallery/gallery-c6f142774af7f32ecc5221618be6378f.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/iconlist/iconlist-49208438ba015017defa07c846d67e90.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/magazine/magazine-c8e42a67fb6deb1a8f1e6fa391ca14f2.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow/slideshow-4e2ef8a1b5c521040e13ed8bbbfa186e.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow/slideshow-video-ac90ef645ad034c5eefab66fa6a89b34.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider/slideshow_layerslider-afc64a1e242444c675746481007edd51.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/tabs/tabs-7107ae0aa394534972c3ba2fba1386b6.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/testimonials/testimonials-a34346ab10d70074aaa423412acaeea4.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/video/video-8ea131869a7170637e7179f41919b89f.js' defer></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-includes/js/imagesloaded.min-3.2.0.js' defer></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-includes/js/masonry.min-3.3.2.js' defer></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery.masonry.min-3.1.2b.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var tve_frontend_options = {"is_editor_page":"","page_events":[],"is_single":"1","ajaxurl":"https:\/\/tomassetti.me\/wp-admin\/admin-ajax.php","social_fb_app_id":"","dash_url":"https:\/\/tomassetti.me\/wp-content\/plugins\/thrive-leads\/thrive-dashboard","translations":{"Copy":"Copy"},"post_id":"3215","ip":"31.193.51.76","current_user":[],"post_title":"Language Server Protocol: A Language Server For DOT With Visual Studio Code","post_type":"post","post_url":"https:\/\/tomassetti.me\/language-server-dot-visual-studio\/","is_lp":"","post_request_data":[]}; /* ]]> */</script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/thrive-leads/tcb/editor/js/dist/frontend.min-2.5.2.2.js' defer></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/thrive-leads/js/frontend.min-2.2.13.2.js' defer></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/themes/enfold/js/aviapopup/jquery.magnific-popup.min-4.5.7.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/avia-snippet-lightbox-af571128e5a33c2149c945f8f248ec6e.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/avia-snippet-sticky-header-0003c940c03fb51010c9767adb23a28b.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/avia-snippet-cookieconsent-d28d2866b8e8786beac2ca70e78174f7.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/avia-snippet-widget-3775c407ef28ce425c794ad4be7c563f.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var tve_dash_front = {"ajaxurl":"https:\/\/tomassetti.me\/wp-admin\/admin-ajax.php","force_ajax_send":"1","is_crawler":""}; /* ]]> */</script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/thrive-leads/thrive-dashboard/js/dist/frontend.min-2.2.14.2.js' defer></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min-5.1.9.js' defer></script> <script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/mootools/1.6.0/mootools-core.min.js'></script> <script type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/enlighter/resources/EnlighterJS.min-3.11.0.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/enlighter/cache/EnlighterJS.init-08b8fc7f4497d8570568ea2382b711c3.js' defer></script> <script data-minify="1" type='text/javascript' src='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/framework/js/conditional_load/avia_google_maps_front-16af321c42711ae8ac9dc4be6671c549.js' defer></script> <script type="text/javascript">var tcb_post_lists=JSON.parse('[]');</script><script type="text/javascript">/* <![CDATA[ */ /*<![CDATA[*/if ( !window.TL_Const ) {var TL_Const={"security":"66a48d5eba","ajax_url":"https:\/\/tomassetti.me\/wp-admin\/admin-ajax.php","forms":[],"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":1,"main_group_id":3264,"display_options":{"allowed_post_types":[],"flag_url_match":false},"shortcode_ids":["4566"],"custom_post_data":{"http_referrer":"http:\/\/blogmarks.net\/api\/marks"},"current_screen":{"screen_type":4,"screen_id":3215},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]};} else {ThriveGlobal.$j.extend(true, TL_Const, {"security":"66a48d5eba","ajax_url":"https:\/\/tomassetti.me\/wp-admin\/admin-ajax.php","forms":[],"action_conversion":"tve_leads_ajax_conversion","action_impression":"tve_leads_ajax_impression","ajax_load":1,"main_group_id":3264,"display_options":{"allowed_post_types":[],"flag_url_match":false},"shortcode_ids":["4566"],"custom_post_data":{"http_referrer":"http:\/\/blogmarks.net\/api\/marks"},"current_screen":{"screen_type":4,"screen_id":3215},"ignored_fields":["email","_captcha_size","_captcha_theme","_captcha_type","_submit_option","_use_captcha","g-recaptcha-response","__tcb_lg_fc","__tcb_lg_msg","_state","_form_type","_error_message_option","_back_url","_submit_option","url","_asset_group","_asset_option","mailchimp_optin"]})} /*]]> */ /* ]]> */</script><script>(function( $ ) {
      "use strict";
		$(function() {
			var $allVideos = $("iframe[src^='https://www.youtube.com']"),
			    // The element that is fluid width
			    $fluidEl = $(".post-entry-type-standard");

				$allVideos.each(function() {
console.log("video found");
					$(this)
						.data('aspectRatio', this.height / this.width)
						.removeAttr('height')
						.removeAttr('width')
					    .removeAttr('style');

				});

				$(window).resize(function() {

					var newWidth = $fluidEl.width();
					var newHeight = 0;
					if(newWidth < 426)
					{
						newWidth = 426;
						newHeight = 240;
					}
					else if(newWidth >= 426 && newWidth < 640)
					{
						newWidth = 426;
						newHeight = 240;
					}					
					else if(newWidth >= 640 && newWidth < 768)
					{
						newWidth = 640;
						newHeight = 360;
					}					
					else if(newWidth >= 768 && newWidth < 800)
					{
						newWidth = 768;
						newHeight = 432;
					}
					else if(newWidth >= 800 && newWidth < 960)
					{
						newWidth = 800;
						newHeight = 450;
					}
					else if(newWidth >= 960 && newWidth < 1024)
					{
						newWidth = 960;
						newHeight = 540;
					}
					else if(newWidth >= 1024 && newWidth < 1280)
					{
						newWidth = 1024;
						newHeight = 576;
					}
					else if(newWidth >= 1280 && newWidth < 1366)
					{
						newWidth = 1280;
						newHeight = 720;
					}
					else if(newWidth >= 1366 && newWidth < 1600)
					{
						newWidth = 1366;
						newHeight = 768;
					}
					else if(newWidth >= 1600 && newWidth < 1920)
					{
						newWidth = 1600;
						newHeight = 900;
					}
					else if(newWidth >= 1920)
					{
						newWidth = 1920;
						newHeight = 1080;
					}					
					
					$allVideos.each(function() {

						var $el = $(this);
						$el
							.width(newWidth)
							.height(newWidth / 16 * 10);
					});
				}).resize();
		});
  }(jQuery));</script> <script>if(document.cookie.match(/aviaPrivacyGoogleTrackingDisabled/)){ window['ga-disable-UA-11421555-5'] = true; }</script><script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-11421555-5', 'auto', {'allowLinker': true});
ga(function(tracker) {
      window.cid = tracker.get('clientId');
});
ga('require', 'linker');
ga('linker:autoLink', ['strumenta.com', 'gumroad.com'] ); 

// anonimizza ip per ottemperare leggi privacy
ga('set', 'anonymizeIp', true);

// invia visita come solito
function delayGALoad(){
   if(window.cid !== undefined){
       ga('send', 'pageview',{'dimension4':  window.cid});
   }else{
       setTimeout(delayGALoad,50)
   }
}
delayGALoad();</script><script type='text/javascript' src='https://stats.wp.com/e-202021.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'70090124',post:'3215',tz:'2',srv:'tomassetti.me'} ]);
	_stq.push([ 'clickTrackerInit', '70090124', '3215' ]);</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script><noscript><link data-minify="1" rel='stylesheet' id='avia-grid-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/grid-e7f86a4957050d86bbdde2be4b2e329c.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-base-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/base-9ee43dd72bee9b2e9372a5d41dfb2cfd.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-layout-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/layout-9d9e2151e6dfc7e5f9e836d3932cd249.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-blog-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/blog/blog-18576e4bf2a5d29be26c86a7d9e1c867.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-postslider-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/postslider/postslider-989c704f7f2a809af837b8e670cd0853.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-button-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/buttons/buttons-134ef1e4b4f1459379c2fc85ac863cbe.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-buttonrow-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/buttonrow/buttonrow-e2c888d48bc63472adaaa4f495043db6.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-button-fullwidth-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/buttons_fullwidth/buttons_fullwidth-254d86a461616beaf79576d06cd34c20.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-catalogue-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/catalogue/catalogue-adbb6d96c9a1738e54bee68a79d32810.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-comments-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/comments/comments-8df61ebd5ffecb3e3d2e0f8dfdba3021.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-contact-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/contact/contact-0f3a49a8560a6238f55c9d2127ffeb76.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-countdown-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/countdown/countdown-7afa04e6b150c054d2c4789014570bac.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-gallery-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/gallery/gallery-7700f83f6eb0be9afd295fd2e1293fea.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-gridrow-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/grid_row/grid_row-a75f88bea377b403e886c709b5ad57cf.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-heading-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/heading/heading-b7dddd1ef4275029a57b9a1517182880.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-hr-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/hr/hr-be01ac5c2ab2e5bdbcfbf150e32877e0.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-icon-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/icon/icon-da0406313b8462d480e535bb05f5f50c.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-iconlist-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/iconlist/iconlist-6088b3605f42a243a31c7547c92e7daa.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-image-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/image/image-2da44520fb6135c9345d7a3f78d7f638.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-magazine-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/magazine/magazine-fc5022a0047a03c485f988cd70381467.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-promobox-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/promobox/promobox-0d9df544506622d9978fcde68065845b.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-slideshow-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow/slideshow-dba83fd5b8d30bff2fd33416275f9c68.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-slideshow-fullsize-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullsize/slideshow_fullsize-fe118d93c104a09fe9cb8f20f63dadb2.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-slideshow-ls-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider/slideshow_layerslider-a349afb13837bc36afbd868e155babf0.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-social-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/social_share/social_share-e981254c3b50efafac2cc9a1c1b9c905.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-tabs-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/tabs/tabs-a7a217b2cdef7d7317f82ac3ff818c81.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-testimonials-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/testimonials/testimonials-6b29171c1f09c44f76fc7f3b18ff6b98.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-module-video-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/video/video-907cc2ae456a4fc8839931e64a286834.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='fi_buttons-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/feedly-insight/css/fi-buttons-deprecated-25fa38b71a8609678b12c06dbaad2860.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='sb_bar-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/swifty-bar/public/assets/css/sb-bar-public-bf0134b2d24b0c6e4e6b5423991a6d0f.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='tve_style_family_tve_flt-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/thrive-leads/tcb/editor/css/thrive_flat-3a109a78ff4eac71f3856ec4009d4665.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='tve_leads_forms-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/thrive-leads/editor-layouts/css/frontend-2.2.13.2.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-scs-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/shortcodes-143bf9025df50d4ca3f24aae5b70c92b.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-popup-css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/js/aviapopup/magnific-popup-3aba24496166b48da31e47e534851e67.css' type='text/css' media='screen' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-lightbox-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/avia-snippet-lightbox-64cad3d2c9d77d18b77c1cf70633f581.css' type='text/css' media='screen' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-cookie-css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/avia-snippet-cookieconsent-bedea0a358c588d449bdd7c4f95a5996.css' type='text/css' media='screen' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-widget-css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/avia-snippet-widget-3bb4c2bac224a946f94a272008eeb881.css' type='text/css' media='screen' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-dynamic-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/uploads/dynamic_avia/tomassetti-214e93ce18069c712a9bbe7dca72a848.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-custom-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/enfold/css/custom-ea2bb2e63ecf88c9937492e1706413c4.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='avia-style-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/themes/tomassetti/style-b224b5538d82adcffaed3add5922da9b.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='easy_table_style-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/easy-table/themes/default/style-61380df45b9199a4a87f6de0f5c2f6ad.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='enlighter-local-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/busting/1/wp-content/plugins/enlighter/resources/EnlighterJS.min-3.11.0.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='jetpack_css-css' href='https://mk0tuzolorusfnc7thxk.kinstacdn.com/wp-content/cache/min/1/wp-content/plugins/jetpack/css/jetpack-cb9b5a4a54629bc9e9f25bd878449a45.css' type='text/css' media='all' /></noscript></body></html>
